tFileOutputDelimited doesn't create the file

Four Stars

tFileOutputDelimited doesn't create the file

I don't know what I'm doing wrong, but I cannot get tFileOutputDelimited to create a file, any file. I've never seen it work yet!
I have a job that eventually creates rows that consist of a single String column, a very long column. In some of the rows, this column is 2000 characters long, in some others it can be as long as 40000 characters.
tFileOutputDelimited actually does create a file, but it's always 0 bytes. I've tried every option in both Basic and Advanced properties; nothing seems to make any difference. I have the row seperator set to "\n", and field seperator set to ";" (figuring that field seperator won't get used anyway, because it's a 1-column set of rows)
This is on Windows 7 64-bit, with TOS Version: 4.2.3 Build id: r67267-20110905-0421
Any ideas on where to look? Thanks for any help ...
Four Stars

Re: tFileOutputDelimited doesn't create the file

I'm wondering if maybe this is a restriction on the number of bytes being written to the file? I have tried small tests with normal size rows (like 80 bytes) and it works OK.
Four Stars

Re: tFileOutputDelimited doesn't create the file

I found my problem -- it was my own fault: I am writing to the file in a subjob, so each execution of the subjob overwrites the row written by that last execution. I needed to check to "Append" mode in tFileOutputDelimited.

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.

Download

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads