tFileInputMail Issue with Omniture Email Attachments

Four Stars

tFileInputMail Issue with Omniture Email Attachments

It appears as though iFileInputMail cannot handle the way that Omniture embeds email attachments (MS Excel Files). Typically, tFileInputMail has no issue with the following format:
===============================
--0015175d095411705604bd5487c5
Content-Disposition: ATTACHMENT;
filename="ACME daily Report.xls"
Content-Type: APPLICATION/VND.MS-EXCEL;
name="ACME daily Report.xls"
Content-Transfer-Encoding: BASE64
===============================

However, with the following, perfectly legal format, the attachment is never attached...
===============================
Content-Disposition: ATTACHMENT;
filename*0="Tracking Code Report for ACME European Rollup - Sat. 31 Mar. ";
filename*1="2012 - Fri. 6 Apr. 2012.xls"
Content-Type: APPLICATION/VND.MS-EXCEL;
charset=UTF-8;
name*0="Tracking Code Report for ACME European Rollup - Sat. 31 Mar. ";
name*1="2012 - Fri. 6 Apr. 2012.xls"
Content-Transfer-Encoding: BASE64
===============================
The second format can be read in GMail just fine, but not in Mac Mail or by the tFileInputMail components.
Does anyone have a workaround?
One Star

Re: tFileInputMail Issue with Omniture Email Attachments

Hi
Could you upload screenshots about issue?
Or we may misunderstand what you mean.
Regards,
Pedro
Four Stars

Re: tFileInputMail Issue with Omniture Email Attachments

Hi
Could you upload screenshots about issue?
Or we may misunderstand what you mean.
Regards,
Pedro

Hi Pedro,
I'm not sure what this screenshot will tell you, but I'm testing the reference design in the component reference...
tPop --> iFileList --> tFileInputMail
For emails that only use "filename" to identify the file in the Content-Disposition detach just fine. The emails that use "filename*0" and "filename*1" to identify the file in the Content-Disposition are not detached at all. It appears that tFileInputMail cannot handle the "filename*" identifiers.
One Star

Re: tFileInputMail Issue with Omniture Email Attachments

Hi ,
I am having same issuue .
I need to fetch attachment file name .
Can anyone tell me how to do that ?
I am using tPop-->tFileList-->tFileInputMail
I am waiting for response
Could you upload screenshots about issue?
Or we may misunderstand what you mean.
Regards,
Pedro

Hi Pedro,
I'm not sure what this screenshot will tell you, but I'm testing the reference design in the component reference...
tPop --> iFileList --> tFileInputMail
For emails that only use "filename" to identify the file in the Content-Disposition detach just fine. The emails that use "filename*0" and "filename*1" to identify the file in the Content-Disposition are not detached at all. It appears that tFileInputMail cannot handle the "filename*" identifiers.