tESBConsumer receiveTimeout

Six Stars

tESBConsumer receiveTimeout

Hello,
we have experienced problem with tESBConsumer component. ReceiveTimeout settings does not do anything.
Version of Talend ESB Open Studio: 5.6.2 (Karaf runtime)
Version of CXF: 2.7.15
I am able to change receiveTimeout by HTTP conduitwhen invoking Web service via HTTP.
I am not able to change receiveTimeout by http conduit when invoking Web service via HTTPS. I verified that my job is using conduit properly. Also tried to change settings on tESBConsumer component (which is according to manual only for Talend Studio purposes).
http conduit is set as follows:
url = https.*
order = 2 (highest order number among conduits)
.... truststore and keystore settings
client.ReceiveTimeout=180000
Basically whatever settings I use, receiveTimeout is always exactly 60 seconds, resulting in java.net.SocketTimeoutException: Read timed out 60 seconds after service invocation.
http conduits and receiveTimeouts work fine when using camel cxf <cxfEndpoint> in blueprints with HTTPS.
Talend Studio v5 is no longer supported I think, but is this known issue? Is it working in latest version of Talend Open Studio as intended?
Simple scenario (though I do not know how to easily create simple web service with SSL in Talend).
1) create web service (with SSL) with sleep > 60s
tESBProviderRequest -> tSleep (100s) -> tESBProviderResponse 
2) create job consuming a service
3) set conduits url and client.ReceiveTimeout.
After looking into source code, tESBConsumer leverages cxf-rt-transport-http and there is
org.apache.cxf.transports.http.configuration.HTTPClientPolicy class. This class sets default 60000ms for ReceiveTimeout. Could it be problem with CXF library?

Thanks, Martin
Six Stars

Re: tESBConsumer receiveTimeout

Ok, made several tests today.
Talend 5.6.2 - configuration does not work.
Talend 6.3.1 - configuration works.