tESBConsumer gives error on selecting 'Populate schema to repository'

Hi Community,
I am facing with an error while trying to invoke a web service using tESBConsumer component.
When I am selecting 'Populate schema to repository on finish',the following error gets displayed on clicking on Finish:
Populate schema to repository: Schema name conflict in collection. Namespace:
Please help me out to resolve this error.
Regards,
Deepti
9 REPLIES

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

Screenshot of the Error:

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

Screenshot of the Error:
Employee

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

(still no any screenshot visible =()
better provide WSDL file you are used for configure tESBConsumer and specify please you Studio version.

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

I have tried attaching the screenshot as file and also through copy paste screenshot., but, it is not appearing in the message.. Smiley Sad
The size of the image is only 151 KB.

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

The version of Talend Studio is 5.6.1. I am getting the following error:
Populate schema to repository: Schema name conflict in collection. Namespace:http://schemas.datacontract.org/2004/07/Microsoft.Dynamics.Ax.Xpp
One Star

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

Suggestion - when in the tESBCsonsumer you choose your operation, try not to populate the schema (ensure the checkbox is unchecked https://help.talend.com/images/54/bk-tos-components-rg-542/use_case_tesbconsumer18.png ) - in fact you don't need to import all client-wsdl definitions and Talend TOS may have problems with very structured data types..

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

Thanks Gabriel for the response.
But, my client wants the option to be selected.
Is it a limitation in Talend that 'Populate schema to repository' option doesn't work with a web-service with multiple ports - operation?
When I tried with one port - 2 operations, it worked.
Regards,
Deepti Bharathan
Employee

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

>> When I tried with one port - 2 operations, it worked.
most probably the problem in schema part which is used by another port(s).
nevertheless what's about to provide your WSDL for check?
One Star

Re: tESBConsumer gives error on selecting 'Populate schema to repository'

Well.. isn't the schema already imported/created ??