tESBConsumer failing: How does one disable Chunking encoding?

One Star

tESBConsumer failing: How does one disable Chunking encoding?

The tESBConsumer works nicely to call a web service.
When one wants to call a web service with a batch load - one can simply configure the tXMLMap that creates the request to tESBConsumer as "All in One" which then collates all the records passed and calls tESBConsumer once.
However - this only works for a web service that works with Chunking encoding enabled. Unfortunately, our production environment does not support Chunking encoding and I need to switch this off.
I know the ESB side one can set Apache CXF client parameters - but HOW does one change it for tESBConsumer so that it DOES NOT use Chunking encoding
The typical error one gets when this is used is:
Caused by: org.apache.cxf.transport.http.HTTPException: HTTP response '411: Length Required' when communicating with https://......
at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponseInternal(HTTPConduit.java:1530)
at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponse(HTTPConduit.java:1490)
Moderator

Re: tESBConsumer failing: How does one disable Chunking encoding?

Hi,
I know the ESB side one can set Apache CXF client parameters - but HOW does one change it for tESBConsumer so that it DOES NOT use Chunking encoding

Please open a jira issue of ESB project on talend bug tracker, our ESB developer will see if it is possible that one change it for tESBConsumer.
Note: Please set the issue type as "Work item".
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.