One Star

tESBConsumer error getting service description

Hi,
I was trying out Talend Open Studio - ESB and I found a strange behaviour.
When trying to configure a tESBConsumer component, I could not configure the component with the web service operation.
The WSDL I tried using was "http:// wsf. cdyne. com/ WeatherWS/ Weather. asmx? WSDL", this got an "Error getting service description: null" error. At first I thought maybe the link was wrong, but I can open it no problem and it shows me a correct WSDL, I then tried using this link to configure another tESBConsumer component, but this time on Talend Open Studio - Data Integration and it worked.
I also tried to use the link that is used in the component guide("http: // www. webservicex. net/ ValidateEmail. asmx? WSDL"), but I still got the same error.
Here's the configuration window in ESB:

Here's the configuration window in DI:

Is this the correct behavior for this component or is it a problem in my Talend Open Studio - ESB?
All of the hyperlinks I posted have spaces in them, as I could not post live links due to forum rules.
Best Regards,
Tiago Vieira
1 REPLY
Community Manager

Re: tESBConsumer error getting service description

Hi 
I tested it on version 6.2.1 and got the same issue, it seems it was a bug and has been fixed in version 6.3.0, see jira issue.
Regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business