tAS400Row and BIGINT

Four Stars

tAS400Row and BIGINT

When selecting the datatypes for my tAS400Output schema I'm unable to choose BIGINT as an option. Can't change the underlying database schema as it's pre-existing. Two questions:

 

1. Any thoughts on how I can resolve this? Is it a driver issue, or a Talend thing? 

 

2. As a short term workaround I was considering a tFlowIterate and building a manual tAS400Row insert statement for each record (non-optimal, I know). Is there a better way to go about doing this?

Twelve Stars

Re: tAS400Row and BIGINT

Yes, Talend - do not allow You to choose BIGINT

 

all depend - how Your components work?

 

if You do not create tables - You could choose long for Talend datatype and for example numeric for database type, Talend will mark this as warning, but not check when execute.

Screen Shot 2018-01-17 at 1.04.58 PM.png

 

 

if You need create table - You can do this as separate tAS400row component and create any structure with plain SQL.


Also, You can edit Talend DataType Mapping (menu - File - Project Settings):

Screen Shot 2018-01-17 at 1.14.03 PM.png

 

and after You will have new type available:

Screen Shot 2018-01-17 at 1.18.07 PM.png

-----------