One Star

[resolved] tNormalize incorrectly splitting all characters

Hi
I have a tFileInputDelimited component reading a .csv file.
This goes to a tNormalize.
In the tNormalize I use "|" as the item separator.
When I run the job column is separates all charactes
Jim|Smith will be delimited as
J
i
m
S
m
i
t
h
with an empty field where the | is.
I have tried reading the file in as ISO-8859-15 and UTF-8.
Please let me know how to resolve this.
1 ACCEPTED SOLUTION

Accepted Solutions
Community Manager

Re: [resolved] tNormalize incorrectly splitting all characters

Hi
try "\\|", it works now.
----------------------------------------------------------
Talend | Data Agility for Modern Business
6 REPLIES
Community Manager

Re: [resolved] tNormalize incorrectly splitting all characters

Hi
try "\\|", it works now.
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] tNormalize incorrectly splitting all characters

Hi,
That worked.
Thanks

Re: [resolved] tNormalize incorrectly splitting all characters

Hi,
I came a problem today, I have a CSV file having data like below:
Field1; Field2; Field3; Field4; Field5; Field6
Field7; Field8; Field9; Field10; Field11; Field12 | Field13; Field14; Field15
.
.
.
Field1; Field2; Field3; Field4; Field5; Field6 | Field4; Field5; Field6 | Field4; Field5; Field6 |........|N
Please let me know how Talend can handle such a problem. So i can map data like:
Field1; Field2; Field3; Field4; Field5; Field6
Field7; Field8; Field9; Field10; Field11; Field12
Field7; Field8; Field9; Field13; Field14; Field15
Target Schema is :
Field1; Field2; Field3; Field4; Field5; Field6
Thanks in advance
Asif
One Star

Re: [resolved] tNormalize incorrectly splitting all characters

I saw that, too, also using the "|" delimiter. It worked properly with the default "," but I have commas in my fields. I tried using "~" and it worked properly.
What's the problem with the "|"??

Re: [resolved] tNormalize incorrectly splitting all characters

It does not recognize "|" and do not normalize fields accordingly.
Five Stars

Re: [resolved] tNormalize incorrectly splitting all characters

With "\\|" works perfect!
Thanks