[resolved] input a csv file

Six Stars

[resolved] input a csv file

Hi,
I have a csv file created in ms excel 2007. Like following:
A06637517,99198598,"dh,och"
A03334761,48574354,robert
A12234344,99200390,nlongom

For the first line, since the third field has a comma in the record, when it's exported from MS excel, it is add "" around the record.
I am wondering how I can handle this in talend to input this csv file. Shall I use FileInputDelimited? If so, how to enter those options?
Thanks.

Accepted Solutions
Highlighted
Six Stars

Re: [resolved] input a csv file

Find out a way.
Useing tfileInputDelimited.
Row separator:"\n" field separator:","
Choose CSV options. Escape char:"\"" and filed Separator:"\""
Hope it could help you too.

All Replies
Highlighted
Six Stars

Re: [resolved] input a csv file

Find out a way.
Useing tfileInputDelimited.
Row separator:"\n" field separator:","
Choose CSV options. Escape char:"\"" and filed Separator:"\""
Hope it could help you too.
One Star

Re: [resolved] input a csv file

I'm having the same problem.
Some sample data (note the description with a comma but enclosed in "")
1,Connectix Cat 5e,003-3NB4-030-06B,Cat 5e RJ45 UTP Lead (3 metre) BLUE,T1,1.78,0.89,Each,S3-E,4000,CONNEC01,003-3NB4-030-06B
1,Connectix Cat 5e,003-3NB4-050-01B,"CCS Cat 5e RJ45 Booted UTP Lead (5 metre, LSZH 26 AWG",T1,3.8,1.9,Each,S3-B,4000,CONNEC01,003-3NB4-050-01B
I have the escape char and field separator set to "\"" but the line is being separated at the comma inside the "".
So this becomes two columns
Col1: CCS Cat 5e RJ45 Booted UTP Lead (5 metre
Col2: LSZH 26 AWG
Which is not what I want.
Any suggestions.
Thanks.
Alan
One Star

Re: [resolved] input a csv file

Sorry should have also mentioned am trying Talend Open Studio 4.2.3r7267 on Ubuntu 10.10 64bit.
Alan