[resolved] error when launching Talend

i m getting the below attached log file as error while launching Talend
Please help ASAP
1 ACCEPTED SOLUTION

Accepted Solutions

Re: [resolved] error when launching Talend

It is working now. I installed 32 bit jdk 1.7.
18 REPLIES
Moderator

Re: [resolved] error when launching Talend

Hi,
It seems the attached log file is missing. Could you please check it then paste log content into forum again?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Re: [resolved] error when launching Talend

!SESSION 2014-04-23 06:49:28.990 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.4.2_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86
!ENTRY org.eclipse.osgi 4 0 2014-04-23 06:49:29.679
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator (Unsupported major.minor version 50.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.eclipse.osgi.baseadaptor.HookRegistry.loadConfigurators(HookRegistry.java:176)
at org.eclipse.osgi.baseadaptor.HookRegistry.initialize(HookRegistry.java:100)
at org.eclipse.osgi.baseadaptor.BaseAdaptor.<init>(BaseAdaptor.java:89)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at org.eclipse.core.runtime.adaptor.EclipseStarter.createAdaptor(EclipseStarter.java:752)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:282)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
!ENTRY org.eclipse.equinox.app 0 0 2014-04-23 06:49:33.644
!MESSAGE Product org.talend.rcp.branding.tos.product could not be found.
!ENTRY org.eclipse.osgi 2 0 2014-04-23 06:49:34.730
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.730
!MESSAGE Bundle update@plugins/org.eclipse.gef.doc.isv.nl_es_3.5.0.v20100814074441.jar was not resolved.
!SUBENTRY 2 org.eclipse.gef.doc.isv.nl_es 2 0 2014-04-23 06:49:34.730
!MESSAGE Missing host org.eclipse.gef.doc.isv_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.730
!MESSAGE Bundle update@plugins/org.eclipse.cvs.nl_it_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.cvs.nl_it 2 0 2014-04-23 06:49:34.730
!MESSAGE Missing host org.eclipse.cvs_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.730
!MESSAGE Bundle update@plugins/org.eclipse.equinox.event.nl_es_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.event.nl_es 2 0 2014-04-23 06:49:34.730
!MESSAGE Missing host org.eclipse.equinox.event_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.730
!MESSAGE Bundle update@plugins/org.eclipse.platform.nl_pt_BR_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.platform.nl_pt_BR 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.platform_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.731
!MESSAGE Bundle update@plugins/org.eclipse.platform.nl_ja_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.platform.nl_ja 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.platform_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.731
!MESSAGE Bundle update@plugins/org.eclipse.pde.core.nl_pt_BR_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.core.nl_pt_BR 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.pde.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.731
!MESSAGE Bundle update@plugins/org.eclipse.pde.ds.core.nl_ru_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.ds.core.nl_ru 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.pde.ds.core_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.731
!MESSAGE Bundle update@plugins/org.eclipse.equinox.launcher.gtk.linux.s390x.nl_de_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.s390x.nl_de 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.s390x_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.731
!MESSAGE Bundle update@plugins/org.eclipse.core.net.linux.x86.nl_es_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.core.net.linux.x86.nl_es 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.core.net.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.731
!MESSAGE Bundle update@plugins/org.eclipse.equinox.launcher.win32.win32.x86.nl_it_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.win32.win32.x86.nl_it 2 0 2014-04-23 06:49:34.731
!MESSAGE Missing host org.eclipse.equinox.launcher.win32.win32.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-04-23 06:49:34.732

Re: [resolved] error when launching Talend

!ENTRY org.eclipse.osgi 4 0 2014-04-23 06:49:35.599
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
Moderator

Re: [resolved] error when launching Talend

Hi,
java.version=1.4.2_12
java.vendor=Sun Microsystems Inc.

Have you already checked document TalendHelpCenter:Compatible Platforms?
For you information, since v4.2.4, Talend requires Sun JDK 1.6 or higher.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Re: [resolved] error when launching Talend

i have installed JDK version 7.
Still i am getting error.
Moderator

Re: [resolved] error when launching Talend

Hi,
Are there two JDK 1.4 and 1.7 in your PC? If so, could you please check your path variable to make sure JDK 1.7 value is set in front of JDK 1.4?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Re: [resolved] error when launching Talend

i removed the other versions. Only 1.7 is available in my system.
Path Variable is also set properly.
Moderator

Re: [resolved] error when launching Talend

Hi,
Is it Working after re-starting computer? Is it the same exception as error log shown in your previous post (java.lang.RuntimeException: No application id has been found.)?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Re: [resolved] error when launching Talend

It is not working after Restart also .
Now i am getting different error as "Failed to Load the JNI Shared Library"
Does Talend is available in 64bit version as my System is 64bit ?
Moderator

Re: [resolved] error when launching Talend

Hi,
Could you please have a look at the related Forum 33355:topic Talend Integration Studio 5.2.1 install / load issue to see if it is helpful for your issue?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Re: [resolved] error when launching Talend

It is working now. I installed 32 bit jdk 1.7.
Moderator

Re: [resolved] error when launching Talend

Hi,
If the issue is closed, may I ask you to click the "Set this topic as resolved" link which is right underneath your initial post? This way, other users will be informed that this thread has been resolved.
Many thanks
Feel free let me know if there is any further help we can give.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] error when launching Talend

Hi Sabrina,
I am same problem. I am doing JasperSoft ETL 5.4.1, while attaching license, i am getting following exception.
!SESSION 2014-05-12 20:31:48.811 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_25
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_IN
Command-line arguments: -os win32 -ws win32 -arch x86_64
!ENTRY org.eclipse.equinox.app 0 0 2014-05-12 20:31:49.850
!MESSAGE Product org.talend.rcp.branding.jetl.product could not be found.
!ENTRY org.eclipse.osgi 2 0 2014-05-12 20:31:50.291
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-12 20:31:50.291
!MESSAGE Bundle reference:fileSmiley Tonguelugins/org.eclipse.equinox.launcher.gtk.linux.x86.nl_ru_3.6.0.v20100814043401.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86.nl_ru 2 0 2014-05-12 20:31:50.291
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.x86_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-12 20:31:50.291
!MESSAGE Bundle reference:fileSmiley Tonguelugins/org.eclipse.help.appserver.nl_de_3.6.0.v20100814043401.jar was not resolved.
resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.ppc64.nl_de 2 0 2014-05-12 20:31:50.327
!MESSAGE Missing host org.eclipse.equinox.launcher.gtk.linux.ppc64_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-12 20:31:50.327
!MESSAGE Bundle org.eclipse.equinox.event.nl_de_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.event.nl_de 2 0 2014-05-12 20:31:50.327
!MESSAGE Missing host org.eclipse.equinox.event_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-12 20:31:50.327
!MESSAGE Bundle org.eclipse.equinox.launcher.motif.aix.ppc.nl_zh_3.6.0.v20100814043401 was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.motif.aix.ppc.nl_zh 2 0 2014-05-12 20:31:50.327
!MESSAGE Missing host org.eclipse.equinox.launcher.motif.aix.ppc_0.0.0.
!ENTRY org.eclipse.osgi 4 0 2014-05-12 20:31:50.327
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)


I am using window 7 64 bit and jdk6 64 bit. Still I am not able to resolve this problem.Please help me.
Thanks and Regards
Karunesh Upadhyay
Moderator

Re: [resolved] error when launching Talend

Hi karunesh,
It will occur error if there is some blank space in installation path or the problem is probably due to long path.
Did you try to reinstall it in another folder and restart it?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] error when launching Talend

1470477907566.log.log
I am getting the error shown in log file while opening talend studio. Can anyone help me here.
Moderator

Re: [resolved] error when launching Talend

Hi navesh,
The log file your provided is not available on talend forum. Could you please take a look at it?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] error when launching Talend

Hello,
I happen to have the same error when installing the talend data integration. I try installing the jdk 1.7/ jdk 7 but still can't install. Then I uninstall the jdk 1.7/ jdk 7 and download and install the jdk 1.8/jdk 8. And it works!! good luck!
One Star

Re: [resolved] error when launching Talend

I am getting a similar error: !MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 51.0