[resolved] Unable to run Talend jobs suddenly

One Star

[resolved] Unable to run Talend jobs suddenly

My computer restarted itself during the night (thanks to Windows update). All of my Talend projects were working fine (had a couple data loads running at the time, too). Now if I try and run any Talend job out of any project, I receive this error:
Execution failed : Failed to generate code.

I've never seen this before, and haven't found anything online in my searches yet. Any ideas?
Thanks

Accepted Solutions
One Star

Re: [resolved] Unable to run Talend jobs suddenly

backing up workspace did the trick!!
thanks all Smiley Happy

All Replies
One Star

Re: [resolved] Unable to run Talend jobs suddenly

I should have noted I was seeing the issue with TOS 5.3.1.
I just imported a project into TOS 5.4 and its working, but I believe this wasn't a "released" version? Am I safe to use this version of Talend?
What is causing 5.3.1 to exhibit that behavior?
Not applicable

Re: [resolved] Unable to run Talend jobs suddenly

I'm having the same problem. I had a bunch of working jobs last Friday, saved, exited, and today can't seem to run any.
Execution failed : Failed to generate code.

Made sure my Java home was set - it is, rebooted the server (Windows). Noticed this is a problem only in TOS; my exported jobs run fine when kicked off using the batch file.
Any help would be appreciated.
Thanks!
One Star

Re: [resolved] Unable to run Talend jobs suddenly

Just this morning I am now having this issue with TOS 5.4. I did notice that a java update was installed this morning, and after that, no Talend jobs will run. Could the java update have changed something? I also checked java_home and path, and they appear fine. As another quick test, I was able to run other java programs from eclipse itself, so I'd think java and the sdk installation is OK.
From the .log file:
!SESSION 2013-10-22 11:24:56.803 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_21
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64
!ENTRY org.talend.platform.logging 1 0 2013-10-22 11:25:05.867
!MESSAGE 2013-10-22 11:25:05,855 INFO org.talend.repository.ui.login.LoginComposite - validate updatesite...

!ENTRY org.talend.platform.logging 1 0 2013-10-22 11:25:23.374
!MESSAGE 2013-10-22 11:25:23,374 INFO org.talend.core.repository.model.ProxyRepositoryFactory - test@talend.com logged on LT_20131010

!ENTRY org.eclipse.ui 2 0 2013-10-22 11:25:23.741
!MESSAGE Warnings while parsing the key bindings from the 'org.eclipse.ui.commands' extension point
!SUBENTRY 1 org.eclipse.ui 2 0 2013-10-22 11:25:23.742
!MESSAGE Cannot bind to an undefined command: plug-in='org.eclipse.xtext.ui', id='org.eclipse.xtext.ui.editor.outline.QuickOutline'
!ENTRY org.talend.platform.logging 1 0 2013-10-22 11:25:24.289
!MESSAGE 2013-10-22 11:25:24,289 INFO org.talend.core.repository.GeneratedJetEmitersLoginTask - Generating JetEmiters

!ENTRY org.talend.platform.logging 1 0 2013-10-22 11:25:24.320
!MESSAGE 2013-10-22 11:25:24,320 INFO org.talend.core.repository.ReadOnlyProjectConfirm - ReadOnly confirm

!ENTRY org.talend.platform.logging 4 0 2013-10-22 11:26:48.075
!MESSAGE 2013-10-22 11:26:48,070 ERROR org.talend.commons.exception.CommonExceptionHandler - Exception onContextJava

Then there is a lot of lines of stack trace. I can add that if it would help.
Thanks
One Star

Re: [resolved] Unable to run Talend jobs suddenly

This is still an issue for me. I do not have time available to research possible causes. Does anyone have any guidance they can provide to possible causes (Talend Team?)? Is there more relevant information that I can provide?
Thanks
Moderator

Re: [resolved] Unable to run Talend jobs suddenly

Hi,
Win 7 32 bit? jdk 1.7?
Please follows the steps as below to restore the items.
1. Back up the workspace.
2. Delete the workspace and restart the studio, if it doesn't work, the studio still crash, you had better to install a new studio.
3. Import all items from the backup of workspace done in step1.
Let me know if it is OK with you.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Unable to run Talend jobs suddenly

Thanks for the input! It looks like backing up the workspace, deleting the workspace, and then re-importing my projects fixed the problem.
Just for reference, Win7 64 bit, jdk 1.7
Moderator

Re: [resolved] Unable to run Talend jobs suddenly

Hi,
Thanks for your feedback. I suspect there is some conflict in your workspace which cause this issue(Unable to run Talend jobs suddenly). We are tracking this issue.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Community Manager

Re: [resolved] Unable to run Talend jobs suddenly

Hi DNewhouse,
If you don't mind, could you send us the workspace that was corrupted (maybe the backup): https://jira.talendforge.org/browse/TDI-28002
I created a JIRA for this.
One Star

Re: [resolved] Unable to run Talend jobs suddenly

Hi,
Even i faced the same issue. Do we need to save all the jobs and close all the jobs after our work gets finished?
Only then, the workspace will not be crashed. Is that so? Or what are the reasons for the software crash?
Regards,
Hermione
Community Manager

Re: [resolved] Unable to run Talend jobs suddenly

Could you possibly send us the corrupted workspace for further investigation?
I'll ping you separately by email if you don't mind.
Many thanks
Elisa
One Star

Re: [resolved] Unable to run Talend jobs suddenly

I haven't checked this thread in a while, so I didn't see the request for corrupted work spaces until now. If this happens again I'll attach the workspace to the JIRA issue. I don't believe I have any copies left over from my previous issue at this time.
Thanks
One Star

Re: [resolved] Unable to run Talend jobs suddenly

backing up workspace did the trick!!
thanks all Smiley Happy

Re: [resolved] Unable to run Talend jobs suddenly

HI,
I installed Talend and tried to run it when I got the error "Unable to execute validation program". As the message is not descriptive, I am not able to probe it.
Can someone help me out on this?
Moderator

Re: [resolved] Unable to run Talend jobs suddenly

Hi mr.mayankagrawal,
Could you please open a new topic for your issue instead of posting it on resolved topic so that other community users have a chance to see it and give a hand to you. Thanks for your understanding.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Employee

Re: [resolved] Unable to run Talend jobs suddenly

I am new to Talend, not familiar with all of the terminology yet, had similar issues and tried several easy things that failed (then I post what worked) -
Failed:
- Shutdown TOS, restart, try several jobs that use to work... all failed the same way
- Restarted the VM I was running TOS on, .... still failed.
Worked:
- Fired up TOS again. "Export Items" (folder icon in TOS, which I think is the same as "backup workspace" w/in this forum thread). Make sure to "select all".
- Restarted TOS, created a new project. "Import Items" (similar folder icon w/in TOS). Select what you previously exported, select all, etc.
- I neglected to delete the old "workspace" because I was gun shy.
- Tried the jobs again. All jobs that worked in my original project worked again.
NOTE: I have attached a .png screen shot of the error on a basic job I was running from the On Demand Training (ODT).