[resolved] The Commandline was running just fine. After a stop it fails to restar

Highlighted
One Star

[resolved] The Commandline was running just fine. After a stop it fails to restar

The Commandline was running just fine. After a stop it fails to restart Command line and TAC as well.
TAC works fine after the server restart, until the CommandLine is started. Once CommandLine starts, TAC immediately stops responding. I tried removing the workspace for commandline on the server, and start it again, but it did not help. I started commandline in the console mode, but there is nothing meaningful either. I'm using Talend 5.4 and it is installed on Linux box.

start_cmdline.bat  start_cmdline.sh  stop_cmdline.bat  stop_cmdline.sh  studio
[color=#000000][size=3][font=Calibri, Arial, Helvetica, sans-serif][root@gfndevinteg cmdline]# ./start_cmdline.sh[/font][/size][/color]
!SESSION 2015-07-11 18:27:03.293 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  --disableShellInput -application org.talend.commandline.Command
Line startServer -p 8002
Command-line arguments:  --disableShellInput -application org.talend.commandline.Comm
andLine -consoleLog -data commandline-workspace startServer -p 8002
 
!ENTRY org.talend.commandline 1 0 2015-07-11 18:27:05.057
!MESSAGE Starting up Command Line Application

Could you plese help me to resolve this issue? 


Accepted Solutions
One Star

Re: [resolved] The Commandline was running just fine. After a stop it fails to restar

Thanks jlolling for your response.
This issue is resolved now.
There was some temporary directory within the cmdline directory structure (not in commandline-workspace directory, but rather some eclipse temporary files), which was causing the problem. I have deleted all recent files that I found in cmdline directory and restored the whole directory from backup, which presumably resolved the issue.

View solution in original post


All Replies
Seventeen Stars

Re: [resolved] The Commandline was running just fine. After a stop it fails to restar

The TAC it self is also not responding?
Got Linux some updates (Java updates?)
Check this:
Start the TAC web application without any other services. Check it and take a look into the Tomcat log file.
Sometimes we see customers starting the TAC and commandline as different user as the start scripts do. Please check the rights on the files system. The default - stupid - behaviour of the installer is to run all services as root. Perhaps there are some chown running in the past to cure this bad behaviour but the start scripts still are trying to do this.
One Star

Re: [resolved] The Commandline was running just fine. After a stop it fails to restar

Thanks jlolling for your response.
This issue is resolved now.
There was some temporary directory within the cmdline directory structure (not in commandline-workspace directory, but rather some eclipse temporary files), which was causing the problem. I have deleted all recent files that I found in cmdline directory and restored the whole directory from backup, which presumably resolved the issue.

View solution in original post

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 2

Part 2 of a series on Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog