[resolved] Talend refuses to start with message "Workspace in use, ... "

One Star

[resolved] Talend refuses to start with message "Workspace in use, ... "

Hi,
I found this morning an issue with Talend Open Studio V3.0.4 running on Linux. Apparently yesterday we experienced an Out of memory error when trying to execute one of the jobs (not sure if that is related or not) but now when trying to load TOS, it shows the splash screen and then a dialog that only says "Workspace in use, cannot start multiple instances at the same time". (there is no other instance of Talend running)
Any idea how to fix that? Because I cant do anything, the program terminates after that dialog so I cannot delete and reimport the project, or change any setting. I was thinking, there is some way to manually edit the project files in order to remove that lock (or something like that)?
Well, hope someone have the answer to this issue.
I would really apreciate any help,
Thanks for your time,

Accepted Solutions

Re: [resolved] Talend refuses to start with message "Workspace in use, ... "

in your '.workspace/metadata' dir, look for a file named '.lock' and remove it. Talend should start.

All Replies

Re: [resolved] Talend refuses to start with message "Workspace in use, ... "

in your '.workspace/metadata' dir, look for a file named '.lock' and remove it. Talend should start.
One Star

Re: [resolved] Talend refuses to start with message "Workspace in use, ... "

Thanks John,
One Star

Re: [resolved] Talend refuses to start with message "Workspace in use, ... "

Thanks, John!
Save my a*s from a crash.
/Patrick