One Star

[resolved] Talend job throwing error "Unable to load dialect & 1.7 not a valid la

We are getting below error when we are poininting java version 1.7 . please help us on the below issue
Exception in component tJavaRow_1
org.drools.RuntimeDroolsException: Unable to load dialect 'org.drools.rule.builder.dialect.java.JavaDialectConfiguration:javaSmiley Surprisedrg.drools.rule.builder.dialect.java.JavaDialectConfiguration'
at org.drools.compiler.PackageBuilderConfiguration.addDialect(PackageBuilderConfiguration.java:283)
at org.drools.compiler.PackageBuilderConfiguration.buildDialectConfigurationMap(PackageBuilderConfiguration.java:268)
at org.drools.compiler.PackageBuilderConfiguration.init(PackageBuilderConfiguration.java:181)
at org.drools.compiler.PackageBuilderConfiguration.(PackageBuilderConfiguration.java:159)
at org.drools.compiler.PackageBuilder.(PackageBuilder.java:210)
at org.drools.compiler.PackageBuilder.(PackageBuilder.java:143)
at org.drools.builder.impl.KnowledgeBuilderFactoryServiceImpl.newKnowledgeBuilder(KnowledgeBuilderFactoryServiceImpl.java:34)
at org.drools.builder.KnowledgeBuilderFactory.newKnowledgeBuilder(KnowledgeBuilderFactory.java:47)
at routines.ForceRuleTLM.readKnowledgeBaseStage1(ForceRuleTLM.java:49)
disconnected
at routines.ForceRuleTLM.(ForceRuleTLM.java:41)
at force3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.tFileInputDelimited_1Process(FOR_TLM_RULES.java:4386)
at fce3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.tJava_5Process(FOR_RS.java:1792)
at for3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.tFileList_1Process(FOR_RS.java:1559)
at for3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.tOracleConnection_2Process(FOR_RS.java:1148)
at force3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.tJava_1Process(FOR_RS.java:1019)
at force3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.runJobInTOS(FOR_RS.java:6333)
at force3_0.force_tlm_rules_0_1.FORCE_TLM_RULES.main(FOR_RS.java:6005)
Caused by: org.drools.RuntimeDroolsException: value '1.7' is not a valid language level
at org.drools.rule.builder.dialect.java.JavaDialectConfiguration.getDefaultLanguageLevel(JavaDialectConfiguration.java:162)
at org.drools.rule.builder.dialect.java.JavaDialectConfiguration.init(JavaDialectConfiguration.java:57)
at org.drools.compiler.PackageBuilderConfiguration.addDialect(PackageBuilderConfiguration.java:279)
... 16 more

4 REPLIES
Moderator

Re: [resolved] Talend job throwing error "Unable to load dialect & 1.7 not a valid la

Hi teena,
Have you already added this parameter in your .ini file of the studio : -Ddrools.dialect.java.compiler.lnglevel=1.6?
Could you please have a look at jira issue https://jira.talendforge.org/browse/TDI-28393?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Talend job throwing error "Unable to load dialect & 1.7 not a valid la

Thanks sabrina for reoly .
i have change .ini -Ddrools.dialect.java.compiler.lnglevel=1.7 from 1.6, but still it is throwing the above error "unable to load dialect " and 1.7 not a valid language .
and also i tried by clicking on the link you sent , it is saying
Hi,
We decided to streamline the process to report defects and Supported Users will NO LONGER be required to create bugs in JIRA before opening a case.
Tickets will be opened and managed directly through our case management system and the tech support engineers level 1 or 2 may eventually create bugs in JIRA upon having confirmed a defect or to enter an enhancement request.
Of course you will continue to have access to the bug entries related to your cases.
Please use the following link to create a ticket if you need a quick answer:
http://www.talend.com/support/customer.pl
Best regards.
The Talend Support Team

i dnt have access to talend professional support, could you help me on above issue .
Moderator

Re: [resolved] Talend job throwing error "Unable to load dialect & 1.7 not a valid la

Hi,
i dnt have access to talend professional support, could you help me on above issue .

You cannot login into Talend Support Portal with your account and password?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Employee

Re: [resolved] Talend job throwing error "Unable to load dialect & 1.7 not a valid la