[resolved] Talend Build Job not creating all needed code items

Highlighted
One Star

[resolved] Talend Build Job not creating all needed code items

I have a job that I have created, and I am trying to export out to an autonomous job. The job is heavily reliant on roughly 25 custom code libriaries that I have created in Talend (stored under code/routines). When I build an autonomous job, it exports the vast majority of these classes, but one custom class (let's call it InterfaceTA) does not get generated and exported.
When I run the job from the Talend Studio, it works just fine. When I try to run the exported job, I get a "classnotfound" error on the InterfaceTA class.
Can anyone help me figure out why Talend is not compiling and exporting that class?
Thank you!

Accepted Solutions
Seventeen Stars

Re: [resolved] Talend Build Job not creating all needed code items

Sometimes unfortunately some routines will not added to the export.
I suggest you close the job, click on the job (right) and open Setup routine dependencies and add all used routines here.

All Replies
Seventeen Stars

Re: [resolved] Talend Build Job not creating all needed code items

Sometimes unfortunately some routines will not added to the export.
I suggest you close the job, click on the job (right) and open Setup routine dependencies and add all used routines here.
One Star

Re: [resolved] Talend Build Job not creating all needed code items

That solved it, thank you so much!

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads