One Star

[resolved] Problem with inserting UTF8 japanese characters in MySQL Database

Hello,
I'm writing in the forum because after days of research I didn't find the solution of this problem. I have Talend 3.1.3 (Open Studio) and what I want to do is:
- from a source in a file (XLS) which contains japanese characters
- with a Tmap component fill correctly the target which is a Mysql table.
I put the source in UTF-8 in the advanced settings
in the MysqlOutput, I also set the encode to UTF-8
The MySQL tables and columns impacted are of interclassement "utf8_general_ci"
When I tried the debugger, I saw in the variables of the source the japanese characters too, I don't understand why the japanese characters in the target are replaced by a "?"
Do you have an idea of this problem? Is it a bug version?
Thanks in advance
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Problem with inserting UTF8 japanese characters in MySQL Database

By searching more in the forum I found a thread who has the solution:
http://talendforge.org/forum/viewtopic.php?id=3253
You have to put "noDatetimeStringSync=true&characterEncoding=UTF-8" in the additionnal jdbc parameters in the advanced settings in the mysqlOutput.
1 REPLY
One Star

Re: [resolved] Problem with inserting UTF8 japanese characters in MySQL Database

By searching more in the forum I found a thread who has the solution:
http://talendforge.org/forum/viewtopic.php?id=3253
You have to put "noDatetimeStringSync=true&characterEncoding=UTF-8" in the additionnal jdbc parameters in the advanced settings in the mysqlOutput.