One Star

[resolved] Problem running Talend job in Windows Scheduler

I am using TOS 5.2.2 and Windows Server 2003 R2.
I have a Talend job that iterates through a database table and sends reminder emails to users under certain conditions.
I exported the job and installed it on the server, as I've done with many jobs currently running successfully on this server in Windows Scheduler.
The problem with this job on Windows Server 2003 R2 is that it runs fine through a Command Window or double clicking the .bat file, but it doesn't seen to run at all from Windows Scheduler (either scheduled or "Run" directly). No error is thrown but it just updates the Last Run Time and goes away.
I also exported a very similar job to another server that is running Windows Server 2008 and it runs fine from Windows Scheduler.
I made sure the path (Start In) is correct and the password is correct, and Security/permissions seem to match other jobs on the systems that work. Any suggestions of what to look at to solve the issue?
Thanks.
1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: [resolved] Problem running Talend job in Windows Scheduler

Hi,
From your description your job .bat file is totally correct. There is nothing wrong in talend side.
Perhaps something wrong with your configuration of Windows Server 2003 R. You'd better check your Windows Server 2003 R2 configuration.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
1 REPLY
Moderator

Re: [resolved] Problem running Talend job in Windows Scheduler

Hi,
From your description your job .bat file is totally correct. There is nothing wrong in talend side.
Perhaps something wrong with your configuration of Windows Server 2003 R. You'd better check your Windows Server 2003 R2 configuration.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.