[resolved] [Problem] Runtime_ESBSE can't deploy a service,

Highlighted
One Star

[resolved] [Problem] Runtime_ESBSE can't deploy a service,

Hi all,
I created a web service which will call a child job during the process, as the snapshots
Parent:

Child:


I did some test and they worked very well when I start web service from TOS for ESB 6.2.
Then I deployed web service to "\container\deploy\filename.kar" successfully. But when I start the Karaf on Windows 10, it can't deploy such service. I did some research but I don't know why. Below shows the error
org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement  osgi.identity; osgi.identity=PriceAPIUpdateService-feature; type=karaf.feature; version=""; filter:="(&(osgi.identity=PriceAPIUpdateService-feature)(type=karaf.feature)(version>=0.1.0)(version<=0.1.0))"  osgi.identity; osgi.identity=PriceAPIUpdateService-control-bundle; type=osgi.bundle; version=""; resolution:=mandatory  osgi.wiring.package; filter:="(osgi.wiring.package=org.talend.esb.job.controller)"]]
at org.apache.felix.resolver.ResolutionError.toException(ResolutionError.java:42)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:235)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:158)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:216)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:263)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1152)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1048)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

I really need some helps. Please!
Thanks,
Scott.

Accepted Solutions
One Star

Re: [resolved] [Problem] Runtime_ESBSE can't deploy a service,

Resolved:
Because I call a child job in parent (with service), it means that the deployed service has dependency:
<dependency>
     <groupId>org.talend.job.</groupId>
     <artifactId></artifactId>
     <version></version>
</dependency>

Therefore, I need to build this child job 
Right click on Job -> Build Job -> choose "OSGI Bundle for ESB" -> choose the save dir ".jar)

This one must be deployed at first before the service. Then, I can deploy my service and it worked perfectly.
Many thanks to the related answer from Tony (http://stackoverflow.com/questions/20016205/unresolved-constraint-in-bundle-missing-requirement-osgi...)
Do you have this bundle installed in your container (Felix) as well?
<dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate</artifactId>
       <version>3.2.6.ga</version>
</dependency>
If not install it and then see what happens when you start your bundle.

Tks,
Scott.

All Replies
One Star

Re: [resolved] [Problem] Runtime_ESBSE can't deploy a service,

It seem that the problem with tRunjob (call child job). I tried to deploy a service without trunjob. It worked well in runtime_esbse/karaf.
Now I have also the error in log file when I deploy service with trunjob:
... org.fire.wiring=routimes.system.api
Anybody can help? Please.
Tks,
Scott.
One Star

Re: [resolved] [Problem] Runtime_ESBSE can't deploy a service,

Resolved:
Because I call a child job in parent (with service), it means that the deployed service has dependency:
<dependency>
     <groupId>org.talend.job.</groupId>
     <artifactId></artifactId>
     <version></version>
</dependency>

Therefore, I need to build this child job 
Right click on Job -> Build Job -> choose "OSGI Bundle for ESB" -> choose the save dir ".jar)

This one must be deployed at first before the service. Then, I can deploy my service and it worked perfectly.
Many thanks to the related answer from Tony (http://stackoverflow.com/questions/20016205/unresolved-constraint-in-bundle-missing-requirement-osgi...)
Do you have this bundle installed in your container (Felix) as well?
<dependency>
       <groupId>org.hibernate</groupId>
       <artifactId>hibernate</artifactId>
       <version>3.2.6.ga</version>
</dependency>
If not install it and then see what happens when you start your bundle.

Tks,
Scott.

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Tutorial

Introduction to Talend Open Studio for Data Integration.

Watch

Downloads and Trials

Test drive Talend's enterprise products.

Downloads

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Download