[resolved] NoClassDefFoundError about tjmsoutput

One Star

[resolved] NoClassDefFoundError about tjmsoutput

Hi
I config the tjmsoutput as attachement, but it run wrongly as follow, how should I do next,thank you !
best wishes
dragon
?16:55 27/06/2012????Copy_of_test_a.
connecting to socket on port 3425
Exception in thread "main" java.lang.Error: java.lang.NoClassDefFoundError: weblogic/security/subject/AbstractSubject
at talenddemosjava.copy_of_test_a_0_1.Copy_of_test_a.tRowGenerator_1Process(Copy_of_test_a.java:753)
at talenddemosjava.copy_of_test_a_0_1.Copy_of_test_a.runJobInTOS(Copy_of_test_a.java:931)
at talenddemosjava.copy_of_test_a_0_1.Copy_of_test_a.main(Copy_of_test_a.java:799)
Caused by: java.lang.NoClassDefFoundError: weblogic/security/subject/AbstractSubject
at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:117)
at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
at javax.naming.InitialContext.init(Unknown Source)
at javax.naming.InitialContext.<init>(Unknown Source)
at talenddemosjava.copy_of_test_a_0_1.Copy_of_test_a.tRowGenerator_1Process(Copy_of_test_a.java:510)
... 2 more
Caused by: java.lang.ClassNotFoundException: weblogic.security.subject.AbstractSubject
at java.net.URLClassLoader$1.run(Unknown Source)
connected
disconnected
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 8 more
?16:55 27/06/2012????Copy_of_test_a?

Accepted Solutions
One Star

Re: [resolved] NoClassDefFoundError about tjmsoutput

Hello,pedro
I follow your instruction,and copy weblogic.jar from %webjogic server%/server/lib/ to <TOS installation dir>\lib\java
but the same problem already exist
Best Regards
dragon

All Replies
One Star

Re: [resolved] NoClassDefFoundError about tjmsoutput

Hi
Please check whether there is a jar file called weblogic.jar in the directory <TOS installation dir>\lib\java.
If not, copy it into this directory.
If it already exists there, you'd better check whether this jar file is from %webjogic server%/server/lib/.
Regards,
Pedro
One Star

Re: [resolved] NoClassDefFoundError about tjmsoutput

Hello,pedro
I follow your instruction,and copy weblogic.jar from %webjogic server%/server/lib/ to <TOS installation dir>\lib\java
but the same problem already exist
Best Regards
dragon
One Star

Re: [resolved] NoClassDefFoundError about tjmsoutput

the problem is solved,thank you for all your help
One Star

Re: [resolved] NoClassDefFoundError about tjmsoutput

the problem is solved,thank you for all your help

Hi
Cuold you share the solution founded, thanks in advance.