One Star

[resolved] Login fault with test.salesforce.com account - known good login

I have a simple Job, it consists of a tSalesForceInput, and a tLogRow output. I'm using the Built-In schema and User Module. I edit the schema and delete all but the first nine columns. I go to tLogRow and Sync columns. I verify my salesforce login. I run the job. I get a login fault, but I know the login is good because I can use it to manually login into test.salesforce.com
I am using a test salesforce account, accessed through https://test.salesforce.com, I cannot access this account via www.salesforce.com, I have to go to test.salesforce.com. Could this be what is causing this, and do I need to do something different to connect to this? This is a "sandbox" account we setup so I would not do things to production data while working on this.
If I try "https:/test.salesforce.com/services/Soap/u/19.0" instead of "https:/www.salesforce.com/services/Soap/u/19.0" I get Connectionrefused.
Is there something special I have to do because I'm using a test account at test.salesforce.com, not a regular account?
This is the error:
Starting job SalesForceTest at 20:48 29/09/2011.

connecting to socket on port 3604
connected
Id Username LastName FirstName Name CompanyName Division Department Title
Exception in component tSalesforceInput_1
org.apache.axis2.AxisFault: Connection refused: connect
at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:203)
at org.apache.axis2.transport.http.HTTPSender.send(HTTPSender.java:76)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(CommonsHTTPTransportSender.java:400)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:225)
at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:435)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:402)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
at com.salesforce.soap.partner.SforceServiceStub.login(SforceServiceStub.java:9868)
at org.talend.salesforce.SforceManagementImpl.login(SforceManagementImpl.java:133)
at talend_test_1.salesforcetest_2_1.SalesForceTest.tSalesforceInput_1Process(SalesForceTest.java:625)
at talend_test_1.salesforcetest_2_1.SalesForceTest.runJobInTOS(SalesForceTest.java:1163)
at talend_test_1.salesforcetest_2_1.SalesForceTest.main(SalesForceTest.java:1027)
Caused by: java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.commons.httpclient.protocol.ReflectionSocketFactory.createSocket(ReflectionSocketFactory.java:140)
at org.apache.commons.httpclient.protocol.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:130)
at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
at org.apache.axis2.transport.http.AbstractHTTPSender.executeMethod(AbstractHTTPSender.java:560)
at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:199)
... 12 more
disconnected
Job SalesForceTest ended at 20:48 29/09/2011.
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Login fault with test.salesforce.com account - known good login

Problem solved. Since this is a sandbox or test account, you have to use a different URL to access salesforce. In my case, I use this:
"https://test.salesforce.com/services/Soap/u/22.0"
and it works fine.
2 REPLIES
One Star

Re: [resolved] Login fault with test.salesforce.com account - known good login

Problem solved. Since this is a sandbox or test account, you have to use a different URL to access salesforce. In my case, I use this:
"https://test.salesforce.com/services/Soap/u/22.0"
and it works fine.
One Star

Re: [resolved] Login fault with test.salesforce.com account - known good login

Problem solved. Since this is a sandbox or test account, you have to use a different URL to access salesforce. In my case, I use this:
"https://test.salesforce.com/services/Soap/u/22.0"
and it works fine.

Yes this works for me as well.