[resolved] Handling Database Warnings with Talend

One Star

[resolved] Handling Database Warnings with Talend

Hi!
I'm receiving this warning message when I insert several data from a CSV file in a Database Table (the violation of a Constraint):
ORA-00001: unique constraint (XXXX.TABLE_UK_1) violated
How can I "ignore" the row that is causing this warning, and continue processing the remaining data?
Thanks.

Accepted Solutions
One Star

Re: [resolved] Handling Database Warnings with Talend

I found that it doesn't appear because the Batch option is selected Smiley Happy
Thanks.

All Replies
Community Manager

Re: [resolved] Handling Database Warnings with Talend

Hi
It have ignored the rows that violates the unique constraint and continue to process the remaining data, if you check the 'die on error' option on DB output component, the job will throw the java exception and stop to execute; if you uncheck the 'die on error' option, the job will capture the problematic rows and continue to execute, link a rejects connector from DB output component to a tLogRow, you will see all the problematic rows, for example:
tFileInputDelimited--main--tOracleOutput--rejects--tLogRow
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Handling Database Warnings with Talend

Thanks, I didn't know that!
Is that 'reject' a component? I'm using "Talend Open Studio for Data Integration, Version: 5.3.1", and I can't find it.
Community Manager

Re: [resolved] Handling Database Warnings with Talend

Hi
It is a connector, not a component, right lick on the tOracleOutput in this case and you will find it in the menu.
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Handling Database Warnings with Talend

That option doesn't appear in my 'tOracleOutput' component... Just the Main option appears.
One Star

Re: [resolved] Handling Database Warnings with Talend

I found that it doesn't appear because the Batch option is selected Smiley Happy
Thanks.