One Star

[resolved] Files not displaying data in tlogrow

Hi Team,
I am trying to display the files in one directory. I have a directory with in that i've 2 csv files. am trying to display those two files in tlogrow which is not showing the data. Am not getting any error at the same time am not able to view the data.
My flow: tfilelist -->iterate --> tfileinputdelimited --> tlogrow.
I've changed in view "_DIRECTORY_" and used global variable in filedelimited. You can see the screenshots.
Please find the screenshots here. I have refered the guides too and still the same problem. You can see first image, Data is moving properly and problem seems to be in displaying the data.
Can anyone tell me the solution? am i missing anything here.
Regards,
Vijayvanamala
1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: [resolved] Files not displaying data in tlogrow

Hi,
Did you set your Field Separator as "," in tFileInputDelimtedted for your input. Wrong format make your input data rejected by tFileInputDelimtedted.
See my screenshots
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
9 REPLIES
Seventeen Stars

Re: [resolved] Files not displaying data in tlogrow

hi,
i've seen nothing "wrong" in your job.
So test to write into file (use append options if needed)
Try to catch value of globalMap to be have goog directory.
but as flowmeter shows you've got data in your flow !
we missed certainly something Smiley Happy
regards
laurent
Moderator

Re: [resolved] Files not displaying data in tlogrow

Hi,
I have seen there is a warning icon in your tfileinputdelimited. Did you set your schema in it, which probably cause the issue"Files not displaying data in tlogrow".
Feel free let me know if there any further help we can give.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Files not displaying data in tlogrow

Hi all,
Yes, there is a warning. But Why we need to specify schema?. what should i give there? Am taking files from a directory and using *.csv. So, what should be given in schema.
Yeah Laurant, I think we missed something. Will find out.

Regards,
Vijayvanamala
Moderator

Re: [resolved] Files not displaying data in tlogrow

Hi,
The component(tfileinputdelimited ) can not read the data without setting column structure. You have to design schema in schema setting according to your column structure.
If your *.csv files are same structure, you can set fixed schema in tfileinputdelimited,
Such as;
ID; Name;SEX
If your *.csv files are different structure, dynamic schema will be necessary for your case(Dynamic schema feature is only available in Talend Enterprise Subscription Version, it allows you to design schema with an unknown column structure).
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Files not displaying data in tlogrow

Hi Sabrina,
As you said, I've defined the schema and am getting data in log. But it is not in table as it should be.
Please see the screen shots. Am i missing something and anything wrong in this.
I have kept only one file in the directory to check this and it seems like reading from the directory bt not displaying in the table.
Moderator

Re: [resolved] Files not displaying data in tlogrow

Hi,
Did you set your Field Separator as "," in tFileInputDelimtedted for your input. Wrong format make your input data rejected by tFileInputDelimtedted.
See my screenshots
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Files not displaying data in tlogrow

Yes got it,
It was the date format issue. previously it was dd-mm-yyyy which is not matching to my input. I changed as u suggested to "dd/mm/yyyy" and it is working.
Thank you and warm Regards,
Vijayvanamala
Moderator

Re: [resolved] Files not displaying data in tlogrow

Hi,
Feel free post your issue on forum.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Seventeen Stars

Re: [resolved] Files not displaying data in tlogrow

actually I missed something Smiley Happy
regards
laurent