[resolved] Failed to generate code

One Star

[resolved] Failed to generate code

Hi, when i run my project, i receive this exception:
Execution failed : Failed to generate code.

can anyone help me? that's mean?
I think that the bug is on tMap_5, because it appear when i create it and i link it with others components.
Thanks

Accepted Solutions
One Star

Re: [resolved] Failed to generate code

Finally my job is working!
I've just deleted a tUnite component, re-created and it works.
Thanks!

All Replies
Community Manager

Re: [resolved] Failed to generate code

Hello
See solutions on 4560.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Failed to generate code

Hi, i see the post and i dont found the solution, because my exception is not at any component,
....
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.GeneratedMethodAccessor144.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.java:467)
... 46 more
Caused by: java.lang.NullPointerException
at org.talend.designer.codegen.translators.common.HeaderJava.generate(HeaderJava.java:529)
... 50 more
I dont know HeaderJava.
can i help me?
thanks.
Community Manager

Re: [resolved] Failed to generate code

Hello
Which version of TOS do you use?
We can't see what's wrong only from the message, Can you export your job and send it to me via email?
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: [resolved] Failed to generate code

Hello,
I'm having the same problem, suddenly when i'm trying to execute my job i'm getting :
Execution failed : Failed to generate code.

and when i'm going to the log i have :
java.lang.NullPointerException
at org.talend.designer.codegen.translators.common.HeaderJava.generate(HeaderJava.java:529)

TOS Version: 4.0.1
thanks

Re: [resolved] Failed to generate code

have you tried good ol 'alt-shift-f3' This should restart the generation engine. this has worked for me with previous versions of talend.
One Star

Re: [resolved] Failed to generate code

alt-shift-f3 does nothing Smiley Sad
any other ideas?
thanks anyway!
One Star

Re: [resolved] Failed to generate code

Finally my job is working!
I've just deleted a tUnite component, re-created and it works.
Thanks!
One Star

Re: [resolved] Failed to generate code

SOLUTION
When the exception is not any component, create a new workspace and import your jobs to it. Simply so.