One Star

[resolved] Escape quotes in tMap?

Hello community,
I need to escape quotes but i have a problem.
I was tried this with replace and replaceAll ("\"","") but doesn't work, i was tried too with replace("&quote",""), but doesn't work
I need remove this quotes before to upload my data, can you help me please?
Thanks in advance
Edit: CSV options:
->field separator: "/t"
->Text enclosure "\""
->Escape char "\""
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Escape quotes in tMap?

Place a tReplace component after the source and as mentioned above configure that component. The output of that component will not have the escape/special character. Put a tLogRow component as the output to tReplace and you can check the result.
Once confirmed, put the real output component like DB output or flat file output
Cheers.
6 REPLIES
One Star

Re: [resolved] Escape quotes in tMap?

Have you tried with tReplace component?
While using it, please uncheck 'whole word' option.
Input Column: Column where this special character has to be removed
Search: The character to be removed (here it is "\"" )
Replace With: ""
Whole Word: Uncheck it ****
One Star

Re: [resolved] Escape quotes in tMap?

ok, i read the edit now. I will try it and i will post the result
Thanks!
One Star

Re: [resolved] Escape quotes in tMap?

Place a tReplace component after the source and as mentioned above configure that component. The output of that component will not have the escape/special character. Put a tLogRow component as the output to tReplace and you can check the result.
Once confirmed, put the real output component like DB output or flat file output
Cheers.
One Star

Re: [resolved] Escape quotes in tMap?

I try it and now its works! thank you so much bkar!
Best regards, Víctor
One Star

Re: [resolved] Escape quotes in tMap?

Nice to hear that it works for you...
Happy coding..
Please mark this post as resolved...
Cheers,
Karthikeyan
One Star

Re: [resolved] Escape quotes in tMap?

sorry i was working in a client and i haven't time, i click on "Set this topic as resolved" but idk if this works, sorry! I have little skill..