[resolved] Error when opening Talend Data Integration Studio

One Star

[resolved] Error when opening Talend Data Integration Studio

A couple of days ago we started getting the following error message when running Talend Data Integration Studio:
?No such user in LDAP" .
We haven't made any changes on our configuration and it was running well until a couple of days before. When i go to check the Talend.log file to see more details i found this trace (note that i removed the username, password and domain information from this trace.):
2013-07-10 12:34:31 INFO RemoteConnectionServlet - Error while using queryString : action=ListProjects&version=5.2.2.r99271&login=user.user%40domain.com&passwd=password
2013-07-10 12:34:31 DEBUG RemoteConnectionServlet - Error while using queryString : action=ListProjects&version=5.2.2.r99271&login=user.user%40domain.com&passwd=password
org.talend.gwtadministrator.server.remoteconnection.ConnectionUtil$LoginException: No such user in LDAP
at org.talend.gwtadministrator.server.remoteconnection.ConnectionUtil.checkUser(ConnectionUtil.java:265)
at org.talend.gwtadministrator.server.remoteconnection.strategy.DefaultConnectionStrategy.execute(DefaultConnectionStrategy.java:125)
at org.talend.gwtadministrator.server.remoteconnection.RemoteConnectionServlet.doGet(RemoteConnectionServlet.java:63)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.talend.gwtadministrator.server.remoteconnection.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:51)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.ajp.AjpAprProcessor.process(AjpAprProcessor.java:448)
at org.apache.coyote.ajp.AjpAprProtocol$AjpConnectionHandler.process(AjpAprProtocol.java:399)
at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1675)
at java.lang.Thread.run(Thread.java:662)

The user that is trying to login do existis in the LDAP directory.
The same error message is also received when you try to login using the Administrator Web console. The message "No such user in LDAP" shows in the login screen right after pressing the Login button, but in the Talend.log file the message that is logged is the following:
2013-07-10 12:34:51 DEBUG TalendRemoteServiceServlet - 11-Starting 'LoginService.login
2013-07-10 12:34:52 DEBUG ClientBusinessExceptionAdapter - key=login.error.unknownUserInLdap|args=[Ljava.lang.String;@44081f03|addMessage=null
2013-07-10 12:34:52 INFO TalendRemoteServiceServlet - 11-Finished 'LoginService.login' in 0 sec.
See images attached.
I really appreciated any hint on how to solve this issue as it isn't allowing us to login to our tool.
Thanks in advanced.
Regards,
Francis.

Accepted Solutions
One Star

Re: [resolved] Error when opening Talend Data Integration Studio

Hi again,
we just found the problem. It was that our AD structure is been modified. So we had to manually update the ldapid column on the user table for each user, so that i matches the new AD structure of those users.
Regards,
Francis

All Replies
Moderator

Re: [resolved] Error when opening Talend Data Integration Studio

Hi,
Could you use the account: admin@company.com password:admin(for the first time) to log in your TAC?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Error when opening Talend Data Integration Studio

Hi Sabrina,
Thanks for your response. Yes it was working fine. it all started a couple of days ago.
Regards,
Francis
One Star

Re: [resolved] Error when opening Talend Data Integration Studio

I think the problem is with the Active directory (AD), cuz when i try to login with fake user, i get the error ,for example: Unknown user 'user@domain.com', which means it do get to connect to the DB and sees that user doesn't exists as a talend user.
In the original error "No such user in LDAP", the system gets to connect to the DB to validate the login but when it goes to the AD to authenticate it, it can't find it and then generate the No such user in LDAP, that's my guess.
Regards,
Francis
One Star

Re: [resolved] Error when opening Talend Data Integration Studio

Hi again,
we just found the problem. It was that our AD structure is been modified. So we had to manually update the ldapid column on the user table for each user, so that i matches the new AD structure of those users.
Regards,
Francis
Moderator

Re: [resolved] Error when opening Talend Data Integration Studio

Hi,
Thanks for your feedback. Feel free post issue on forum.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Error when opening Talend Data Integration Studio

hi
i have the same probleme i have this message when i connect ADM
Unknown user 'admin@compagny.com'

i don't have had user and i don't delete the user
What is the problem
One Star

Re: [resolved] Error when opening Talend Data Integration Studio

hi
i have the same probleme i have this message when i connect ADM
Unknown user 'admin@compagny.com'

i don't have had user and i don't delete the user
What is the problem

Unknown user 'admin@compagny.com'

the good user is admin@company.com
^^

thanks