One Star

[resolved] Error While Invoking the Job as a WebService.

Hi,
I have Exported the job in Talend MDM 5.3.1(Open Studio) as a WebService(WAR) and deployed it in local JBoss server. When I am trying to invoke from the browser using the URL "http://localhost:8080/modify_job2_0.1/services/modify_job2?method=runJob" getting below error.
This XML file does not appear to have any style information associated with it. The document tree is shown below.
<soapenv:Envelope>
<soapenv:Body>
<soapenv:Fault>
<faultcode>ns1Smiley Frustratederver.NoService</faultcode>
<faultstring>The AXIS engine could not find a target service to invoke! targetService is modify_job2</faultstring><detail>
<ns2:hostname>Leader-PC</ns2:hostname>
</detail>
</soapenv:Fault>
</soapenv:Body>
</soapenv:Envelope>
Is there any Bug in Talend MDM 5.3.1(Open Studio) version regarding the Web Service Creation?
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Error While Invoking the Job as a WebService.

Hi Sabrina,
Thank you. Actually there was a problem with my workspace. I changed my workspace and now it is working fine.
Regards,
Pratap G.
4 REPLIES
Moderator

Re: [resolved] Error While Invoking the Job as a WebService.

Hi,
The AXIS engine could not find a target service to invoke! targetService is modify_job2

If the job works well in Talend MDM 5.3.1, I suspect something wrong with your JBOSS configuration. Is it working in Tomcat?
Would you mind checking the article http://stackoverflow.com/questions/7013783/how-to-deploy-a-war-file-in-jboss-as-7.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Error While Invoking the Job as a WebService.

Hi Sabrina,
Thank you. Actually there was a problem with my workspace. I changed my workspace and now it is working fine.
Regards,
Pratap G.
Moderator

Re: [resolved] Error While Invoking the Job as a WebService.

Hi,
Thanks for your feedback.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Error While Invoking the Job as a WebService.

Hi,
Thanks for your feedback.
Best regards
Sabrina

I am having similar problem. I have hosted my job on Weblogic Server.
<soapenv:Envelope xmlns:soapenv="" xmlns:xsd="" xmlns:xsi="">

<soapenv:Body>
<soapenv:Fault>
<faultcode xmlns:ns1="">ns1Smiley Frustratederver.NoService</faultcode>
<faultstring>
The AXIS engine could not find a target service to invoke! targetService is TransFormAndLoadService1
</faultstring>
<detail>
<ns2:hostname xmlns:ns2="">SFB-LP-16</ns2:hostname>
</detail>
</soapenv:Fault>
</soapenv:Body>

</soapenv:Envelope>

I have created the service named TransFormAndLoadService1.
please suggest.