[resolved] ERROR in FTP to local drive transfer (tFTPGet)

Highlighted
One Star

[resolved] ERROR in FTP to local drive transfer (tFTPGet)

Hi, 
May be a newbie question but I am just getting started with Talend Open Studio. I am trying to FTP a file from a remote ftp server to my local drive. The job completes with error code = 0 (success). However I see an error tag on the tFTPGet component. Also the file does not get copied over from remote server to local drive. 
What am I doing wrong ? Screenshots attached.

Accepted Solutions
One Star

Re: [resolved] ERROR in FTP to local drive transfer (tFTPGet)

I downloaded the file successfully after "Pause Protection" on the Kaspersky Internet Security 2017. Kaspersky network protection blocks active ftp mode from Talend. Wierdly enough it allows from filezilla or filezilla implements it differently. Not sure. 
I'll now adjust kaspersky to allow active on 21 and re-enable protection. 
Thanks all for your time

View solution in original post


All Replies
Forteen Stars

Re: [resolved] ERROR in FTP to local drive transfer (tFTPGet)

in which mode You connect to this FTP normally?
is it FTP(port 21) or sFTP(port 22)?
if plain ftp:
- think ascii mode for binary file it is not right mode, change it
- is Your file really located in ROOT folder? (/game_bakup_1.db)
-----------
One Star

Re: [resolved] ERROR in FTP to local drive transfer (tFTPGet)

in which mode You connect to this FTP normally?
is it FTP(port 21) or sFTP(port 22)?
if plain ftp:
- think ascii mode for binary file it is not right mode, change it
- is Your file really located in ROOT folder? (/game_bakup_1.db)


I am trying in ACTIVE mode and FTP (21)
I tried both in binary and ascii. It should be in Binary as i have BLOBs in the db file
My FTP user has a ftp home to blablablabla/backup set on user level thus for my user the home directory contains the file i am trying to ftp over to local. on Filezilla it looks like screenshot i attached.

I tried to check box "print error message" in ftp get. I see it says ACTIVE mode is not supported please use passive. However, I am connected to ftp server via filezilla using active(passive wont work). Passive is not supported by server due to security issues (number of ports open)
One Star

Re: [resolved] ERROR in FTP to local drive transfer (tFTPGet)

I downloaded the file successfully after "Pause Protection" on the Kaspersky Internet Security 2017. Kaspersky network protection blocks active ftp mode from Talend. Wierdly enough it allows from filezilla or filezilla implements it differently. Not sure. 
I'll now adjust kaspersky to allow active on 21 and re-enable protection. 
Thanks all for your time

View solution in original post

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 2

Part 2 of a series on Context Variables

Blog

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog