[resolved] Custom Component Deployment to TAC

Six Stars

[resolved] Custom Component Deployment to TAC

Hi,
   I have a custom component(from TalendExchange) working fine in the Studio on my desktop.  I'm trying to deploy it in my distributed TAC environment and am getting compile errors that the custom componet is not loaded.  I copied the the custom .jar files to the "User Component Path" directory and still getting errors.  Can someone kindly direct me to the instructions for deploying to TAC.
Thanks!
Andy

Accepted Solutions
Six Stars

Re: [resolved] Custom Component Deployment to TAC

Thanks, Sabrina for your replies.  Yes, that directory was already configured under Commandline.  I just figured it out and got it to work.  Previously, I only copied the .jars for the custom component to that directory referenced under Commandline.  Once I copied the entire custom component folder to that directory, it worked just like in studio on my desktop. (this is a remote linux box just running jobserver and commandline. No studio is run from there).

View solution in original post


All Replies
Moderator

Re: [resolved] Custom Component Deployment to TAC

Hi Andy,
Which product and version do you have?
Have you already checked your TAC configuration to see if the user component path has been set under commandline.
See my screenshot


Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: [resolved] Custom Component Deployment to TAC

Thanks, Sabrina for your replies.  Yes, that directory was already configured under Commandline.  I just figured it out and got it to work.  Previously, I only copied the .jars for the custom component to that directory referenced under Commandline.  Once I copied the entire custom component folder to that directory, it worked just like in studio on my desktop. (this is a remote linux box just running jobserver and commandline. No studio is run from there).

View solution in original post

Moderator

Re: [resolved] Custom Component Deployment to TAC

Hi agt0613,

Thanks your feedback. It's great that your issue is fixed. Please mark this topic as resolved.

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables

Blog

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog