Four Stars

[resolved] Could not generate DH keypair when sign-in

I want to log in Talend (TOS Version: 5.6.1) to get new component in Exchange. 
So I go to TOS -> Window -> Preferences -> Talend -> Exchange  -> Sign-in  and fill in email/pass but TOS can not go to my account or raise any errors on screen. 
When checking TOS log , I see "Could not generate DH keypair" error.
I hope someone can help me out.
Many thanks.
talend_log.sql_20150529-0922.sql   
5 REPLIES
Moderator

Re: [resolved] Could not generate DH keypair when sign-in

Hi,
Are you using MAC OS?
Please take a look at a jira issue:https://jira.talendforge.org/browse/TUP-2929.
For the moment, this is the workaround: 
Download component on exchange.talend.com and load it in the studio, more help please read this documentation.
https://help.talend.com/search/all?query=Installing+a+custom+component&content-lang=en
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: [resolved] Could not generate DH keypair when sign-in

@xdshi: I am using Window 7 ,  so how can I sign-in ?
I added new component from exchange by using your link (it's cool).
Thanks.
Moderator

Re: [resolved] Could not generate DH keypair when sign-in

Hi,
Thanks for your quick feedback. We are investigating this "Sign-in" issue.
What's your java version? 1.7?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: [resolved] Could not generate DH keypair when sign-in

@xdshi: 
- OS: Win 7 - 64 bit 
- TOS v5.6
- JAVA_HOME = C:\Program Files\Java\jdk1.7.0_75   (Java 1.7).
I have TOS: v5.0.2 and v5.6 on the same computer. With TOS v5.0.2 , sign-in function is fine.
Moderator

Re: [resolved] Could not generate DH keypair when sign-in

Hi,
I have TOS: v5.0.2 and v5.6 on the same computer. With TOS v5.0.2 , sign-in function is fine.

Thanks your response. Currently we are aware of the problem, the problem does not lie on "exchange" but between Studio and MyTalend, , we will come back to you when we will have found and fixed it.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.