One Star

[resolved] Cannot build job in Talend Studio

Hello guys,
We created multiples jobs in TOS, and they are working perfectly except for one which works when we run it, but doesn't want to build nor work on our server when we deploy it.
Example :
I run it in talend studio, it works and do his job. It even builds but when we deploy it on the server, it crashes (or do nothing, with no logs whatsoever). When we try to build it before running it once in TOS (when we start the studio anew), it crashes.
Errors are never the same, we got "org.talend.designer cannot be resolved", "org.talend cannot be resolved", "org.talend.designer.components.lookup.memory ..." or even some Jaxen-related crashes.
We use the same kind of pattern in others jobs without problem. Faulty job's attached.


Problem arised when we added contexts parameters to the job, but doesn't seem to go away when we replace these parameters by hard coded ones.
Any insight ?
(TOS 6.1.1)
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Cannot build job in Talend Studio

Hello,
We finally found what was causing this problem in our job. The tMDMConnection was acting funny and would work if we did not connect the others tMDM components directly to the server (with hardcoded url&parameters) before using tMDMConnection to handle it.
Marked as resolved.
7 REPLIES
One Star

Re: [resolved] Cannot build job in Talend Studio

Hello,
I had the same kind of error with one of my process. I never found what 's wrong.
To fix the problem I create a new job from scratch (exactly the same). The new one was working well.
I'm wokring with TOS 6.1.1
One Star

Re: [resolved] Cannot build job in Talend Studio

Hello sinowak,
We did try that before, with no success. Actually even if it worked, that wouldn't be an acceptable workaround, seeing if may happen again in others job.
Better fix that for good, but thanks for the answer !
One Star

Re: [resolved] Cannot build job in Talend Studio

Update :
During our extended testing, we found that it seems to be related to the matching mode in the lookup relation.
The complete error is "Exception in thread "main" java.lang.NoClassDefFoundError: org/talend/designer/components/lookup/common/ICommonLookup$MATCHING_MODE
"
We still didn't find anything that could help, though.
Moderator

Re: [resolved] Cannot build job in Talend Studio

Hi,
Does this issue repro after restarting your PC?
Could you please try to remove your tLogRow components from your job design to see if you can deploy it on runtime with no error?
Is there any error message which is located in runtime\container\log\tesb.log ?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Cannot build job in Talend Studio

Hello Sabrina, thanks for the answer.
We tried, but restarting doesn't fix the problem. In fact, we have it on 3 different computers, with different specs.
I tried to to remove the tLogRow, to no effects. And we don't have any log in tesb other than other working jobs.
In fact, when we succeed in building the job (always after running it one time in studio), it deploys with no apparent problem on the server. Excepted that it doesn't work and doesn't generate logs.
One Star

Re: [resolved] Cannot build job in Talend Studio

Hello,
We finally found what was causing this problem in our job. The tMDMConnection was acting funny and would work if we did not connect the others tMDM components directly to the server (with hardcoded url&parameters) before using tMDMConnection to handle it.
Marked as resolved.
Moderator

Re: [resolved] Cannot build job in Talend Studio

Hi,
Thanks for your feedback and posting that you have resolved it by yourself.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.