[resolved] Cannot build any standalone job in TOS-DI 6.3

One Star QR
One Star

[resolved] Cannot build any standalone job in TOS-DI 6.3

Hello !
I had to import and deploy a project from Talend DI 6.2 (Enterprise) to TOS DI 6.3. I adapted the code for that version (such as tParallelize...).
With the enterprise version, i was able to build my jobs without any problem. With the TOS, the building of my jobs as "Standalone Job" generates an empty zip file. I tried to create a new project and build a new job : no file generated either.
I can successfully build "Axis WebService (War and Zip)" and "OSGI Bundle For ESB".
I do have a JDK 1.8, and it is the only one set in my Talend Preferences.
As said in this post : Unable to build jobs in 6.0.1, the java -version and %JAVA_HOME% path displayed on cmd are rigth (1.8).
(https://www.talendforge.org/forum/viewtopic.php?id=46263)
My company doesn't have a proxy (in case of error with Maven settings).
I tried what was in this similar post : 6.0.1 Cannot build standalone job, except the link to routine not compiling, as i don't know how to find the failing routine in .JAVA in the Navigator view.
(https://www.talendforge.org/forum/viewtopic.php?id=46377)
Finally i have this message in log when i build my job :
INFO  org.eclipse.m2e.core.internal.lifecyclemapping.LifecycleMappingFactory  - Using NULL lifecycle mapping for MavenProject:

Note that i use the default settings of Talend, for both enterprise and open versions. I see the same messages in Error Log view in both versions.
I will upload my log if needed.
My OS is Windows 7 64bits.
Do you have an idea ?
Thanks,
Quentin
EDIT: links added (under the 10 posts limit to add hyperlinks)

Accepted Solutions
One Star QR
One Star

Re: [resolved] Cannot build any standalone job in TOS-DI 6.3

Hello Sabrina,
Thanks for your reply.
Yes I created and deployed my project on TIS 6.2, and then imported, corrected, and tried to deploy it again on TOS DI 6.3.
Yes I tried to create a new project (tFixedFlow --- tLogRow) and export it as Standalone job, without success.
As you said you couldn't repro, i just tried again with a fresh install of TOS with all the default settings, and i was able to successfully build both a simple test project and my main project imported from my first install of TOS.
The only difference i see between the two installs is the paths : the successfull one doesn't contain blank spaces. Is this a coincidence or might it have an impact ?
I am going to mark this topic as solved.
Thanks again for your help !

All Replies
Moderator

Re: [resolved] Cannot build any standalone job in TOS-DI 6.3

Hi,
I had to import and deploy a project from Talend DI 6.2 (Enterprise) to TOS DI 6.3. I adapted the code for that version (such as tParallelize...).

You exported your TIS 6.2 project and imported it into Talend open studio 6.3? Actually, there are some features only available in talend subscription version not open source. Not sure that your adaptation of the code is totally correct.
Have you tried to create a new project and a simple job on talend open studio V 6.3? And then exporting your job as "Standalone Job" to see if it works? 
We have made a testing on V 6.3 and cannot repro your issue.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star QR
One Star

Re: [resolved] Cannot build any standalone job in TOS-DI 6.3

Hello Sabrina,
Thanks for your reply.
Yes I created and deployed my project on TIS 6.2, and then imported, corrected, and tried to deploy it again on TOS DI 6.3.
Yes I tried to create a new project (tFixedFlow --- tLogRow) and export it as Standalone job, without success.
As you said you couldn't repro, i just tried again with a fresh install of TOS with all the default settings, and i was able to successfully build both a simple test project and my main project imported from my first install of TOS.
The only difference i see between the two installs is the paths : the successfull one doesn't contain blank spaces. Is this a coincidence or might it have an impact ?
I am going to mark this topic as solved.
Thanks again for your help !
Moderator

Re: [resolved] Cannot build any standalone job in TOS-DI 6.3

Hi,
Thanks for your feedback.
Talend don't allow an extra blank space in installation path.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.