One Star

[resolved] Always 1 awaiting exec. Message

Hello,
I am having a problem with running jobs in Talend Administrator Center, for the first time I run the jobs everything is OK, then when i try to run again i got the message: 1 awaiting exec. But there is nothing in the queue.
So, I have to delete the job and add it again, so I can run for the first time. 
The problema is that every time I will run this job I have to do this.
Does anyone knows what can be happening?
Thanks
Best regards
7 REPLIES
Moderator

Re: [resolved] Always 1 awaiting exec. Message

Hi,
What's the Talend version you are using ? Could you please try to close down TAC and Tomcat and then restart it to see if it is OK with you?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Always 1 awaiting exec. Message

Hello,
I am using Talend Enterprise Data Quality 5.0.3, i already restarted Tac, Tomcat and CommandLine, but nothing happened.
Thank you
One Star

Re: [resolved] Always 1 awaiting exec. Message

Hello,
After restarted both: machine and Apache Tomcat, the first time I click Run it works fine, but when i click Run again, it stays with the message 1 Awaiting exec forever. I am thinking if its something peculiar to Solaris SPARC, because i never saw it before.
It seems like its frozen, when i see jobserver.log, nothing happened there, the log is:
2015-03-31 10:54:43,414 INFO  TalendJobServer - =========== JobServer successfully started ===========
2015-03-31 10:55:18,425 WARN  TypedProperties - !!! PROPERTY NOT FOUND !!!: the key 'org.talend.monitoring.jmx.server.OsInfoRetriever.OS_PARTITIONS' can't be found in the JobServer properties file, the default value '[]' will be used, please be sure this is not an anomaly.
2015-03-31 11:01:34,446 INFO  JobOutputManager - System property "traceFileHandles.dirPath" has the value 'null', traceFileHandles will be disabled.

Is there any other logs I can see?
I really appreciate if you have more ideas, about what is happening.
Thank you
Best Regards
One Star

Re: [resolved] Always 1 awaiting exec. Message

I don´t know yet why this problem occurred, but I reinstalled Apache Tomcat and changed default port from 8080 to 8081 and it worked fine.
Moderator

Re: [resolved] Always 1 awaiting exec. Message

Hi,
http://localhost:8081 is working for you? Is the port <8080>  used by your some instance or job?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Moderator

Re: [resolved] Always 1 awaiting exec. Message

Hi,
Can we consider this topic as resolved?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Always 1 awaiting exec. Message

Sure,
It´s solved.
The port 8080 was not in use by another application.