[resolved] Activemq deploy error

Highlighted
One Star

[resolved] Activemq deploy error

Hi all,
I try to deploy a route with cJms in Runtime-esb, to read a queue message.
My route :

when I try deploy the route in Runtime-esb i have the following error message : 


14:10:50,897 | WARN  | container/deploy | araf.kar.internal.KarServiceImpl  219 | 36 - org.apache.karaf.kar.core - 4.0.1 | Unable to install Kar feature Test2-feature/1.0.0
org.osgi.service.resolver.ResolutionException: Unable to resolve org.ops4j.pax.web.pax-web-extender-whiteboard/4.2.0: missing requirement [org.ops4j.pax.web.pax-web-extender-whiteboard/4.2.0] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.ops4j.pax.web.extender.whiteboard.runtime)(version>=4.2.0))"
at org.apache.felix.resolver.Candidates.checkSubstitutes(Candidates.java:521)[org.eclipse.osgi-3.10.2.jar:]
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:246)[org.eclipse.osgi-3.10.2.jar:]
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:220)[8:org.apache.karaf.features.core:4.0.1]
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:263)[8:org.apache.karaf.features.core:4.0.1]
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1079)[8:org.apache.karaf.features.core:4.0.1]
at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:975)[8:org.apache.karaf.features.core:4.0.1]
at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_71]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_71]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_71]
at java.lang.Thread.run(Thread.java:745)[:1.7.0_71]

Accepted Solutions
Highlighted
One Star

Re: [resolved] Activemq deploy error

I find how work with Activemq, my version of Karaf was 4.0.1 and i switch it for 2.3.9 and it works very well.

View solution in original post


All Replies
Highlighted
One Star

Re: [resolved] Activemq deploy error

I find how work with Activemq, my version of Karaf was 4.0.1 and i switch it for 2.3.9 and it works very well.

View solution in original post

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

An API-First Approach to Modernizing Applications

Learn how to use an API-First Approach to Modernize your Applications

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read