Five Stars

prompting for Passphrase in the automated job

Hello

 

I'm stuck at a point in my automated job. I have given all the details regarding decryption in the job and its automated. During the scheduled run its asking for a passphrase to enter manually and the job is failing. I've given the passphrase in the context as well. I used kleopatra to generate my public key. I'm not understanding how to stop it from prompting me a passphrase. Please help me out if there is a solution.

 

Thanks,

Surya.

2 REPLIES
Moderator

Re: prompting for Passphrase in the automated job

Hello,

Would you  mind posting your automated job setting screenshots on forum?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: prompting for Passphrase in the automated job

Hello @xdshi,

 

I've actually found a solution and its not prompting me for a passphrase anymore in the scheduled job.

Instead of using tGPGdecrypt we used tsystem component.

we've created a windows batch file with this below command

gpg --pinentry-mode=loopback --passphrase %1 -o %2 -d %3

where,

%1- "YOUR PASSPHRASE"

%2- DESIRED OUTPUT FILE PATH

%3- ENCRYPTED SOURCE FILE PATH

We call this batch file in tsystem as given below

context.Batch_job + " " +context.v_passphrase + " " + context.Output_file + " " + context.src_file

where context.batch_job- "D:\Code\emp_decrypt.bat"

Hope this helps others.