org.talend.core.model.components.IComponentsService n'a pas été enregi

One Star

org.talend.core.model.components.IComponentsService n'a pas été enregi

Bonjour,
I store my workspace folder on the network and at one point the network server went down on us.
Once the file server was back online, I restarted TOS and I got the following message:
java.lang.RuntimeException: Le service org.talend.core.model.components.IComponentsService n'a pas été enregistré.
at org.talend.core.GlobalServiceRegister.getService(Unknown Source)
at org.talend.repository.model.ComponentsFactoryProvider.getInstance(Unknown Source)
at org.talend.core.CoreService.componentsReset(Unknown Source)
at org.talend.core.repository.model.ProxyRepositoryFactory.logOnProject(Unknown Source)
at org.talend.repository.ui.login.LoginDialog$1.run(Unknown Source)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
What should I do to recover from that error preventing me to start with the Project I normally work with?
What are my options to resume my work as much as possible?
Thanks.
PM
One Star

Re: org.talend.core.model.components.IComponentsService n'a pas été enregi

Resolved by looking into the following thread:
http://www.talendforge.org/forum/viewtopic.php?id=2809
Cheers.
PM
One Star

Re: org.talend.core.model.components.IComponentsService n'a pas été enregi

Better than a redirection, the soluce there :
Just remove folder
workspace\.metadata\.plugins\org.eclipse.core.resources\.root\.indexes
and restart TOS.
My pleasure