One Star

encoding problem in tfileoutputdelimited

Hello,
I'm new to talend, and I got a problem today when i read a excel file contains polish characters, and output to csv file.
the workflow is  tfileinputExcel->tmap->tfileoutputdelimited
all the special character, like '??', became '?'.  
I try to set  both of input and output encoding to  'UTF-8' or 'ISO-8859-15' in the advanced settings , but it did not work.
I couldn't find solution in forum, can anybody please help? 
Thanks.
11 REPLIES
Five Stars

Re: encoding problem in tfileoutputdelimited

Hi Luo Jun,
the output back to an excel file works in my test case.
Did you add the input file to the meta data? Did you see the '?' also in preview?
Best regards
Frank
One Star

Re: encoding problem in tfileoutputdelimited

Hi Frank,
yes, i can see the characters correct in metadata, aslo output to excel file  is ok.
Five Stars

Re: encoding problem in tfileoutputdelimited

How do you open the csv file? With Excel I get weird characters, but with Notepad for example I can see the correct characters.
One Star

Re: encoding problem in tfileoutputdelimited

I have no problem to open the csv and excel output file directly.
Five Stars

Re: encoding problem in tfileoutputdelimited

Em, sorry ... What I mean:
You wrote that special polish characters became '?' in csv. Do you open that file in Excel?
My test case reads an xls-file and outputs it to an csv- and an xls-file. I can open both files in Excel. The xls-file is shown correct, but not the csv-file. When I open the csv-file with Notepad I can see the special polish characters.
One Star

Re: encoding problem in tfileoutputdelimited

the polish characters is also '?' when I open the csv file in Excel.
Five Stars

Re: encoding problem in tfileoutputdelimited

Ok. Is your problem solved now? Or do you have to get a csv-file and open it in Excel?
One Star

Re: encoding problem in tfileoutputdelimited

No,  the issue is still not solved. 
also '?' in the csv file opening in Excel.
One Star

Re: encoding problem in tfileoutputdelimited

I have changed my computer  'region and language',  change system region from Chinese to English,
 then, the csv file can be opened in notepad correctly, and also right when I open the file from Data-?from text in Excel.
but not right in Excel direct opening.
Also, I have test this in amazon cloud, original English OS, it the same to the case one.
So, it seems that the issue is related to system configuration.
can anyone help?
Five Stars

Re: encoding problem in tfileoutputdelimited

issue is with source encoding, go to the advance setting of tFileInputDelmited and select encoding then write "windows-1252" 
then check whether it works or not. i used to have same problem. 
One Star

Re: encoding problem in tfileoutputdelimited

Hi Umesh,
It didn't work.