One Star

enable the loadFromRemoteSources switch

Hi,
I used tDotNETInstantiate and tDotNetRow components in my simple job.\
While running the job, i'm getting error as below;
Where should i change the loadFromRemoteSources?
Starting job UseCase_3 at 14:55 01/02/2016.
connecting to socket on port 3571
connected
System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.
   at System.Reflection.RuntimeAssembly.nLoadFile(String path, Evidence evidence)
   at System.Reflection.Assembly.LoadFile(String path)
   at Java_org_talend_net_Object_loadAssmbly(JNIEnv_* env, _jclass* _this, _jstring* libPath)
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  Internal Error (os_windows_x86.cpp:149), pid=7472, tid=8352
#  guarantee(result == EXCEPTION_CONTINUE_EXECUTION) failed: Unexpected result from topLevelExceptionFilter
#
# JRE version: 7.0_03-b05
# Java VM: Java HotSpot(TM) 64-Bit Server VM (22.1-b02 mixed mode windows-amd64 compressed oops)
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Bharath\Software\Talend-Studio-20141207_1530-V5.6.1\Talend-Studio-20141207_1530-V5.6.1\hs_err_pid7472.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Job UseCase_3 ended at 14:55 01/02/2016.
Regards,
R.Bharath
1 REPLY
Moderator

Re: enable the loadFromRemoteSources switch

Hi R.Bharath,
On which build version you got this issue? Have you already checked component references about:TalendHelpCenter:tDotNETInstantiate and TalendHelpCenter:tDotNETRow?
Could you please upload your job setting screenshots into forum which will be helpful for us to address your issue?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.