One Star

downgrade from 5.1.1 to 5.0.2

hello,
I have created my jobs in talend version 5.1.1 but now i need to downgrade to the version 5.0.2.
I am unable to import the jobs.
Can anyone help me please? it is urgent...
thanks
11 REPLIES
One Star

Re: downgrade from 5.1.1 to 5.0.2

Hi,
Make sure you are doing the import/export in right way to check that you can create a dummy job probably with a tFixedFlowInput and tLogRow component, run it and once you are sure it's running fine then export it somewhere. delete the current job from "Job Designes" as well as from "Recycle bin", and try to import the exported job in same environment this way you can be sure you are doing the right thing. If something is missing fix it or else follow the steps given below.
Probably you would have to downgrade your exported files. I believe there should not be much difference between these versions apart of some fixes. If that is the case then following should work.
1) Open exported job folder.
2) Find file "talend.project", open it with any text editor like notepad in windows.
3) Find tag "TalendProperties"
4) Inside that tag find following element "productVersion"
5) Change its values from "Talend Open Studio for Data Integration-5.1.1" to "Talend Open Studio for Data Integration-5.0.2", please make sure to provide full major/minor version. like 5.0.2.r78327 instead of 5.0.2
Please do let me know if it works.
--
Regards,
Vinod
Seven Stars

Re: downgrade from 5.1.1 to 5.0.2

I believe you also need to remove incompatible migration tasks from the talend.project file (search other forum topics on this) but basically it's not supported and might not work properly even if you can import it.
Community Manager

Re: downgrade from 5.1.1 to 5.0.2

Hi
It is not supported that downgrade from an higher version to a lower version. You can't import the items export from higher version into lower version, if you found a bug on the current version you are using, it is better report it to our bugtracker, Talend have many developers are working on the project and the bugs are usually fixed quickly on the next release. Afterwards, you can upgrade product into the new version.
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: downgrade from 5.1.1 to 5.0.2

Agreed,
If you are working on two different environments then try to updrade the lower version env. to higher version. In any case upgrade is the better option than downgrade at least for open source.
--
Regards,
Vinod
One Star

Re: downgrade from 5.1.1 to 5.0.2

Thanks a lot
One Star

Re: downgrade from 5.1.1 to 5.0.2

Information sharing and communication is very important because without proper information, advancement and
improvement is not possible.Thanks for sharing information.
One Star

Re: downgrade from 5.1.1 to 5.0.2

Hi,
I have not been able to downgrade the version of my job.
I had to rework all.
Thanks.
One Star

Re: downgrade from 5.1.1 to 5.0.2

Unfornately,
I am passing for the same problem, and I cannot downgrade my job version, maybe i'll have to rewrite all jobs.
I anyone have another solution i appreciate, I'll keep trying.
Thanks
Community Manager

Re: downgrade from 5.1.1 to 5.0.2

Unfornately,
I am passing for the same problem, and I cannot downgrade my job version, maybe i'll have to rewrite all jobs.
I anyone have another solution i appreciate, I'll keep trying.
Thanks

This is no possible, you have to re-create all the jobs. If you find any bugs on the new version, feel free to report them on Talend bugtracker. Our developers will fix them asap in next version.
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Five Stars

Re: downgrade from 5.1.1 to 5.0.2

Hi,
I have a similar situation here.   My company had Studio Enterprise Version: 5.6.1 installed on a server but I had Version: 5.6.2 installed on my workstation.  I cannot import the jobs to the server because it has an older version.
I guess I have to uninstall and reinstall Version: 5.6.1 and re-build all those jobs, right?  The server already had production jobs running and they are not going to upgrade to Version: 5.6.2 any time soon.  Any other options?
Thanks
Fifteen Stars

Re: downgrade from 5.1.1 to 5.0.2

This can usually be done between minor version changes, but it is not supported and not recommended. The way to do is it to study the changes between the versions. To do that, create a simple job in 561. Export it and import it into 562. Export that. Then explode the 561 and 562 zips and compare the job properties files. Make a note of the differences and try and add those changes to the 562 export you want to downgrade. As I said, it is not supported though.
Rilhia Solutions