components <tInitLog4J,tLog4J> are not loaded in T.D.I 5.2.2

One Star

components <tInitLog4J,tLog4J> are not loaded in T.D.I 5.2.2

Hi,
I try to generate and deploy an application in TAC but two customs components not loaded by the T.D.I. I have a follow error :
org.talend.commons.exception.PersistenceException: Process cannot be opened because some used components <tInitLog4J,tLog4J> are not loaded
at org.talend.designer.core.ui.editor.process.Process.checkLoadNodes(Process.java:2063)
at org.talend.commandline.util.JobHandler.export(JobHandler.java:246)
at org.talend.commandline.command.CommandProcessor.doExportJob(CommandProcessor.java:291)
at org.talend.commandline.command.CommandProcessor.exportJob(CommandProcessor.java:210)
at org.talend.commandline.command.CommandProcessorSwitch.caseExportJobCommand(CommandProcessorSwitch.java:94)
at org.talend.commandline.client.util.CommandAbstractSwitch.doSwitch(CommandAbstractSwitch.java:66)
at org.talend.commandline.command.CommandConsumer.executeCommand(CommandConsumer.java:57)
at org.talend.commandline.command.CommandConsumer.execute(CommandConsumer.java:35)
at org.talend.commandline.mode.ServerCommandLine$CommmandConsumerRunnable.run(ServerCommandLine.java:139)
at java.lang.Thread.run(Thread.java:662)
org.talend.gwtadministrator.client.module.dashboard.commandline.model.CommandLineBean.executeGroupCommand(CommandLineBean.java:183)
org.talend.administrator.scheduler.business.job.generate.JobGenerator.executeGroupCommand(JobGenerator.java:278)
org.talend.administrator.scheduler.business.job.generate.JobGenerator.generate(JobGenerator.java:145)
org.talend.administrator.scheduler.business.ExecutionTaskHandler.generateJobScriptUnit(ExecutionTaskHandler.java:379)
org.talend.administrator.scheduler.business.ExecutionTaskHandler$1.run(ExecutionTaskHandler.java:321)
Caused by: org.talend.commons.exception.PersistenceException: Process cannot be opened because some used components <tInitLog4J,tLog4J> are not loaded
at org.talend.designer.core.ui.editor.process.Process.checkLoadNodes(Process.java:2063)
at org.talend.commandline.util.JobHandler.export(JobHandler.java:246)
at org.talend.commandline.command.CommandProcessor.doExportJob(CommandProcessor.java:291)
at org.talend.commandline.command.CommandProcessor.exportJob(CommandProcessor.java:210)
at org.talend.commandline.command.CommandProcessorSwitch.caseExportJobCommand(CommandProcessorSwitch.java:94)
at org.talend.commandline.client.util.CommandAbstractSwitch.doSwitch(CommandAbstractSwitch.java:66)
at org.talend.commandline.command.CommandConsumer.executeCommand(CommandConsumer.java:57)
at org.talend.commandline.command.CommandConsumer.execute(CommandConsumer.java:35)
at org.talend.commandline.mode.ServerCommandLine$CommmandConsumerRunnable.run(ServerCommandLine.java:139)
at java.lang.Thread.run(Thread.java:662)
Question : How generate and deploy my application in T.D.I using customs components?
Regards
Moderator

Re: components <tInitLog4J,tLog4J> are not loaded in T.D.I 5.2.2

Hi,
Did you follow up the article TalendHelpCenter:Installing a custom component to install custom components <tInitLog4J,tLog4J> in studio? Is your job working well in studio?
In addition, have you set "User component path" in configuration of TAC(see my pic)?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.