client.ReceiveTimeout parameter

Six Stars

client.ReceiveTimeout parameter

Hello everyone,

I'm trying to change this parameters for my jobs, and my previous modification modifying the file didn't had any effect.
I change the
org.apache.cxf.http.conduits-common.cfg


because I didn't knew how to properly name my file, so I used what I believed was the main file, and added my conf :

client.ConnectionTimeout=120000

client.ReceiveTimeout=120000


I now think that I have to name file properly or activate this "common" file.
Do you have any clue to apply this settings ? Where can I find endpoints ? Karaf prompt me for an endpoint name to have an endpoint list, which : "You don't know the answer ? Give me the answer and I will give you the answer !!"

Thank you for you time.

Sincerely,

Accepted Solutions
Employee

Re: client.ReceiveTimeout parameter

Hi, rmartin,

By default the etc/org.apache.cxf.http.conduits-common.cfg is used by "https" transport conduit, you can add another one for "http" e.g. etc/org.apache.cxf.http.conduits-abc.cfg which looks like:
order = 2
url = http://localhost.*
client.ConnectionTimeout=240000
client.ReceiveTimeout=240000

For more information, please find https://help.talend.com/pages/viewpage.action?pageId=271836899


Regards.

All Replies
Employee

Re: client.ReceiveTimeout parameter

Hello
let me tell you this feature is only for ESB. 
The naming of the file does not matter. You need to put the correct URL. e.g. Something like you are accessing a external webservice with tESBConsumer component and webervice in general takes more time to reply back. Then you create separate conduit file, put the part of (or complete) URL  ending with * there. 
Six Stars

Re: client.ReceiveTimeout parameter

Sure, I'm using it in TOS ESB, for Webservices jobs.
I'm using a tESBConsumer, which request for a localhost service (I have a front and a backoffice WS).
Since I was not sure about regexp syntax in this file, which was by default "url=http://localhost.*" ; I assumed that it was meaning "everything under localhost".

Actually my file look exactly like this :

###
# #%L
# Talend :: Assembly
# %%
# Copyright (C) 2011 - 2012 Talend Inc.
# %%
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
#      http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.
# #L%
###

#Common SSL conduit configuration

url = https://localhost.*

tlsClientParameters.disableCNCheck = true
tlsClientParameters.trustManagers.keyStore.type = JKS
tlsClientParameters.trustManagers.keyStore.password = password
tlsClientParameters.trustManagers.keyStore.file = ./etc/keystores/keystore.jks
tlsClientParameters.keyManagers.keyStore.type = JKS
tlsClientParameters.keyManagers.keyStore.password = password
tlsClientParameters.keyManagers.keyStore.file = ./etc/keystores/keystore.jks
tlsClientParameters.keyManagers.keyPassword = password
tlsClientParameters.trustManagers.keyPassword = password

tlsClientParameters.cipherSuitesFilter.include = .*_EXPORT_.*,.*_EXPORT1024_.*,.*_WITH_DES_.*,.*_WITH_AES_.*,.*_WITH_NULL_.*,.*_DH_anon_.*

client.ConnectionTimeout=120000
client.ReceiveTimeout=120000

And I just saw that it was "https".... Can I put many "url" and paramarters in the same file or should I split them ? There's not much documentation on the internet.
I'm going to remove that "s" and tell you if it's ok.
Can you confirm that will be ok if I ask for "http://localhost:8040/services/MyWebservice"  with the actual regexp ?


Update @6pm :

I've used the following parameters :

Pid:            org.apache.cxf.http.conduits.fbeb7b06-246b-4ba5-84c5-a64b98283ee7
FactoryPid: org.apache.cxf.http.conduits
BundleLocation: mvn:org.apache.cxf/cxf-rt-transports-http/3.1.4
Properties:
client.ConnectionTimeout = 240000
client.ReceiveTimeout = 240000
felix.fileinstall.filename = file:/opt/Talend/Runtime_ESBSE/container/etc/org.apache.cxf.http.conduits-common.cfg
service.factoryPid = org.apache.cxf.http.conduits
service.pid = org.apache.cxf.http.conduits.fbeb7b06-246b-4ba5-84c5-a64b98283ee7
tlsClientParameters.cipherSuitesFilter.include = .*_EXPORT_.*,.*_EXPORT1024_.*,.*_WITH_DES_.*,.*_WITH_AES_.*,.*_WITH_NULL_.*,.*_DH_anon_.*
tlsClientParameters.disableCNCheck = true
tlsClientParameters.keyManagers.keyPassword = password
tlsClientParameters.keyManagers.keyStore.file = ./etc/keystores/keystore.jks
tlsClientParameters.keyManagers.keyStore.password = password
tlsClientParameters.keyManagers.keyStore.type = JKS
tlsClientParameters.trustManagers.keyPassword = password
tlsClientParameters.trustManagers.keyStore.file = ./etc/keystores/keystore.jks
tlsClientParameters.trustManagers.keyStore.password = password
tlsClientParameters.trustManagers.keyStore.type = JKS
url = http://localhost:8040/*

and still, it does not work (I received a timeout after 60 sec).

Any clues ?

PS : the command "cxf:list-endpoints" shows my 6 endpoints correctly.


Sincerely.
Six Stars

Re: client.ReceiveTimeout parameter

Hi everyone,

Still no clue on how to make this parameters active ?
Six Stars

Re: client.ReceiveTimeout parameter

Hello everyone,

Sorry to bother you again with my problem but I'm still unable to process big XML file because of this timeout.
Your help will be really appreciated, I'm kinda desperate for solutions...

Thank you in advance.

Sincerely,
Employee

Re: client.ReceiveTimeout parameter

Hi, rmartin,

By default the etc/org.apache.cxf.http.conduits-common.cfg is used by "https" transport conduit, you can add another one for "http" e.g. etc/org.apache.cxf.http.conduits-abc.cfg which looks like:
order = 2
url = http://localhost.*
client.ConnectionTimeout=240000
client.ReceiveTimeout=240000

For more information, please find https://help.talend.com/pages/viewpage.action?pageId=271836899


Regards.
Six Stars

Re: client.ReceiveTimeout parameter

Thank you for your help, I will try it this evening and report the results.


Sincerely,

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read