Z/OS FTP file get

Five Stars

Z/OS FTP file get



I am using Talend to fetch a data file from our IBM mainframe. I installed the FTP JAR and it allows me to make an FTP connection. I can log in and get a directory of what is in the mainframe using the get file list component. However, I do not seem to be able to get an individual file using tFTPGet. 


How are the pathnames in the mainframe specified in Talend tFTPGet? I used FileZilla FTP Client to get into the mainframe see the file and the file is there, so it's not permissions related. I wonder if I specified the remote path and file mask correctly. I used:


Remote Path:   "XXXX.YYYY.ZZZZ"

Files: "MYFILE"

The path on the mainframe is XXXX.YYYY.ZZZZ.MYFILE


Do I need to specify the ending . in the remote path? that's the only thing I am thinking, perhaps Z/OS is not as forgiving? I know that on Z/OS there are no 'folders' or 'directories' the way we have them on Unix or Windows. What is the trick for specifying the remote path and name?


Thank you,





Twelve Stars

Re: Z/OS FTP file get

What is you talend Version?

Francois Denis

Tag as "solved" for others! Kudos to thanks!

Five Stars

Re: Z/OS FTP file get

It is 7.01, integration studio free version. I even tried the dot at the end of the remote path. No error but tFTPGet does not fetch the file.
Five Stars

Re: Z/OS FTP file get

It is the latest 7.01 free version (we're evaluating)


The plot thickens. If I specify files in my 'home directory' or what passes as such on Z/OS the files can be retrieved with tFTPGet with no problem. So if I have my user ID called ZUSERID and three files of type .CSV under my home directory, tFTPGet works perfectly.


I specify "ZUSERID." as the remote path and "*.CSV" as the file mask and all 3 files arrive as expected.

But, when I try this in another 'home directory' for which I have access, it does not work.

i.e. if I specify "ZANOTHERID.SUBDIR"  as the remote directory and "XXXXX.YYYY.FILENAME" as the file name it does not work. 


The issue is that it seems to work if the file is in the top level directory immediately following the first dot. But a file deeper in the file system i.e. ZANOTHERID.SUBDIR.XXXXXX.YYYYY.FILENAME will not work (note ZANOTHERID is the root directory, SUBDIR is the subdirectory, and XXXX.YYYY.FILENAME is the filename.


Using Filezilla I was able to find out which part is the 'directory' and which is the file name. I specified it correctly, no success either. It seems to work only if the file is at the top level directory. It's not a permissions problem either, I have access. If the file is in root folder it works.


Any suggestions?

Five Stars

Re: Z/OS FTP file get

Any suggestions? I think it is the interface JAR that does not seem to work the way it works on non-IBM mainframe FTP targets...


Talend named a Leader.

Get your copy


Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 1

Learn how to do cool things with Context Variables


Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema


Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables