XSLT version

One Star

XSLT version

Hi,
are XSLT 2.0 features supported in Talend by the tXSLT component?
If not, will they be supported soon in future?
Thanks!
One Star

Re: XSLT version

Or another question:
I saw you are using Xalan in Talend. Is it possible to select another XSLT processor, like Saxon, by setting the Transformer Factory?:
System.setProperty("javax.xml.transform.TransformerFactory", "net.sf.saxon.TransformerFactoryImpl");
Thanks!
One Star

Re: XSLT version

I'm trying the same thing. I added the line you postet to the main method of the project. That seems to work, so The Job is searching for saxon now but i don't know where to put the saxon .jat file. Can anybody help?
Thanks
One Star

Re: XSLT version

I see these questions haven't been answered, and I've run into similar issues, can someone offer suggestions please?
My difficulty is that I need to process an XSLT 2.0 stylesheet but get syntax errors when run through a tXSLT component, because of Xalan I presume.
I hate to bulk up the packaged jobs I create with copies of saxon, but that's the only way I can successfully run the job. Changing the stylesheet is not an option.
Is it possible to tell Talend to use an XSLT processor other than Xalan? If so, how?
Thanks,
-Chris
Community Manager

Re: XSLT version

Hello Chrisk
Is it possible to tell Talend to use an XSLT processor other than Xalan? If so, how?

You can report a feature on our bugtracker.
Best regards

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: XSLT version