Writing to Salesforce

One Star

Writing to Salesforce

Hi. I'm new using Talend so I'm still playing around with a few aspects and I'm having some problems. I'm trying to write to Salesforce, either from a csv file or from one Salesforce instance to another. I successfully connected to both instances and created the map, but when I run it, I get the following error: (I'm just trying to copy a few accounts from one instance to the other. Nothing fancy)
Starting job SFtoSF at 11:02 17/08/2010.
connecting to socket on port 3375
connected
Exception in component tSalesforceOutputBulkExec_1_tSBE

at com.sforce.async.RestConnection.parseAndThrowException(RestConnection.java:109)
at com.sforce.async.RestConnection.doHttpGet(RestConnection.java:279)
at com.sforce.async.RestConnection.getBatchResultStream(RestConnection.java:247)
at org.talend.salesforceBulk.SalesforceBulkAPI.getBatchLog(SalesforceBulkAPI.java:291)
at testsftosf.sftosf_0_1.SFtoSF.tSalesforceInput_1Process(SFtoSF.java:2552)
at testsftosf.sftosf_0_1.SFtoSF.runJobInTOS(SFtoSF.java:2778)
at testsftosf.sftosf_0_1.SFtoSF.main(SFtoSF.java:2652)
disconnected
Job SFtoSF ended at 11:02 17/08/2010.
Now I'm using the tSalesforceOutputBulkExec as the component that connects to the instance being written to. Is this correct? I've been able to write from SF to a file, but am having trouble writing back to Salesforce. If anyone could tell me or point me to a good tutorial, I'd really appreciate it.
Thank you in advance!
Community Manager

Re: Writing to Salesforce

Hi
Which version of TOS do you use?
Best regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Writing to Salesforce

Hi.
I'm using TOS 4.1.0.M3_r46036. Any help would be greatly appreciated?
Thanks!
One Star

Re: Writing to Salesforce

I've just had the same message and corrected the error. It was simply that I had the wrong field name in the schema, so salesforce couldn't load the data.
I had a field called "AccountName" that should have just been "Name". I changed the field name and it ran fine.
Hope this helps
Rick
One Star

Re: Writing to Salesforce

Hi
Which version of TOS do you use?
Best regards
Shong

I'm using 4.1.1r50363