Four Stars

Using tSalesforceInput to get related record fields

Hi all, 

 

I am trying to use the tSalesforceInput component to get the related record(parent) fields.

 

This is the query I want to execute:

 

SELECT Id, ABI_CM_Wholesaler__r.ABI_SFA_External_ID__c FROM ABI_CM_CountrySetting__c

 

I saw this in the user manual:

 

To retrieve a column from a linked module it is necessary to define the column in a particular manner in the Edit schema view, otherwise the relationship query will not work. The correct syntax is: NameofCurrentModule_NameofLinkedModule_NameofColumnofInterest

 

However, I am unable to get it to work

 

I'm working with custom objects:

 

Child object: ABI_CM_CountrySetting__c

Lookup field name: ABI_CM_Wholesaler__c

Parent object type: Account

Wanted field on the parent object: ABI_SFA_External_ID__c

 

I've tried with:

ABI_CM_CountrySetting__c_ABI_CM_Wholesaler__c_ABI_SFA_External_ID__c

ABI_CM_Wholesaler__c_ABI_SFA_External_ID__c

 

I did not succeed with any of these, I always get the error:

 

No such column 'ABI_CM_Wholesaler__c_ABI_SFA_External_ID__c' on entity 'ABI_CM_CountrySetting__c'.

 

Has anyone been able to get this to work?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Four Stars

Re: Using tSalesforceInput to get related record fields

I did try that, but it did not work at first.

 

I did get it to work around an hour ago. The key thing here is that my field names contain an underscore. If that is the case, you must set up tSalesforceInput with a manual query and add a ABI_CM_Wholesaler__r_ABI_SFA_External_ID__c in the schema (the same as in query, but the underscore replaces the dot).

 

 

2 REPLIES
Twelve Stars TRF
Twelve Stars

Re: Using tSalesforceInput to get related record fields

Hi,

Did you try "ABI_CM_Wholesaler__r_ABI_SFA_External_ID__c"?

(not sure, I can't try actually).


TRF
Four Stars

Re: Using tSalesforceInput to get related record fields

I did try that, but it did not work at first.

 

I did get it to work around an hour ago. The key thing here is that my field names contain an underscore. If that is the case, you must set up tSalesforceInput with a manual query and add a ABI_CM_Wholesaler__r_ABI_SFA_External_ID__c in the schema (the same as in query, but the underscore replaces the dot).