Using tLog or Length / Precision hangs the job

Highlighted
Five Stars

Using tLog or Length / Precision hangs the job

Hello Guys,
I am trying to extract data from a Lotus Notes database using a custom component (not sure if this changes anything because the extraction part actually works, so...) into a MSSQL DB.
I realized that if I copy the schema from the target DB back to the tMap component, it will fill the Length / Precision for all the fields. I'd be fine with that, since it gets rid of the ! sign complaining about schema differences. But it hangs my job in the middle of the load. No errors, all numbers just stall.
If I remove Len/Prec from tMap, the job works, BUT if I add a tLog in the middle of tMap and MSSQL output, the problem comes back.
I've been stuck with this problem for a couple days now, do any of you guys have any experience with this bug? How to work around it?
Thanks!
Helvio
Moderator

Re: Using tLog or Length / Precision hangs the job

Hi,
Does this issue repro on tFileOutPutxxx component instead of using tLogRow? Could you please show your job setting screenshots into forum?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Best Practices for Using Context Variables with Talend – Part 4

Pick up some tips and tricks with Context Variables

Blog

How Media Organizations Achieved Success with Data Integration

Learn how media organizations have achieved success with Data Integration

Read

Agile Data lakes & Analytics

Accelerate your data lake projects with an agile approach

Watch