User routines not working in routes

One Star

User routines not working in routes

I have Talend Open Studio for ESB 6.1.1 and I am having troubles exporting my user routines when I build the route. When I run the job from the studio, everything works perfectly, but as soon as I build the kar file and deploy the route in the runtime, the job throws an error every time that a user routine is referenced.
How can I use user routines when I build and deploy my routes?
The caused by message is shown below:
Caused by: java.lang.NoClassDefFoundError: routines/VixtaUtils
at integration.afs_tank_readings_receiver_0_1.AFS_Tank_Readings_Receiver$3.process(AFS_Tank_Readings_Receiver.java:160)
at org.apache.camel.processor.DelegateSyncProcessor.process(DelegateSyncProcessor.java:63)
Community Manager

Re: User routines not working in routes

It seems like a bug, have you tested it also on the latest version 6.2.1?
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: User routines not working in routes

I have not tried that as we would have to migrate our ESB servers to the newest open source version. 
If you are looking to replicate the issue, you will need to reference a user routine from the route itself rather than in a DI job. It also must be a user routine and not a bean class.

15TH OCTOBER, COUNTY HALL, LONDON

Join us at the Community Lounge.

Register Now

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read