Upgrade a JDBC Driver

One Star

Upgrade a JDBC Driver

After installation of Talend Open Studio 6.2/6.3 PostgreSQL  V9.4  configuration uses driver postgresql-9.4-1201.jdbc41.jar.  PostgreSQL recommends using postgresql-9.4.1212.jar for java 1.8 environment.
It is easy to change the driver in the job for delivery but I didn’t find a way to change it in Open Studio workbench.
Can anyone help me to solve this problem?
Regards Dirk 
Moderator

Re: Upgrade a JDBC Driver

Hi,
The driver files are in the maven repository. Check you own repository (user-home/.m2/repositories/org/talend/libraries/)
Could you please try to rename your new .jar file with the old one(rename postgresql-9.4.1212.jar as postgresql-9.4-1201.jdbc41.jar) and restart your studio to see if it works?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Seventeen Stars

Re: Upgrade a JDBC Driver

I am currently working on an update and will suggest Talend this. In this update is also included the latest JDBC driver.
But for now: Please try to load the recent driver with tLibraryLoad at the earliest possible time in your job.
One Star

Re: Upgrade a JDBC Driver

Hi Sabrina,
this works, thanks a lot.
In my Windows installation the repository is located in
<talend home>\configuration\.m2\repository\org\talend\libraries\
Is it planned to provide a function for this in future releases?
Regards Dirk
Seventeen Stars

Re: Upgrade a JDBC Driver

Poisoning the maven is a very ugly solution and will not work in the enterprise release.
I cannot hardly imagine, Talend will provide such a function to "tweak" the maven this way. It violates a clean software engineering.
Moderator

Re: Upgrade a JDBC Driver

Hi,
Thanks for your suggestion. Feel free to create a new feature/work item jira issue on talend bug tracker.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.