Five Stars

Updating the mysql-connector jar file to be used.

Hi,
I am in the process of updating the mysql-connector jar being used and am not sure where to define what
jar file is to be used. I want to go from using the mysql-connector-java-5.1.0-bin.jar file to using the more
current mysql-connector-java-5.1.14-bin.jar file.
I had replaced the mysql-connector-java-5.1.0-bin.jar file with the mysql-connector-java-5.1.14-bin.jar file in the .../workspace/Java/lib folder and that did not seem to work - it looks like this is a working directory due
to the newer jar file getting replaced with the old jar file (5.1.0) once I went back into the Talend tool.
Is there a config file somewhere that states what jar file is to be used?
Btw... I am using version 5.0.2
Thank you in advance.
Regards,
Tom
3 REPLIES
One Star

Re: Updating the mysql-connector jar file to be used.

try this:
Window --> Show View --> Talend --> Modules
an extra tab appears where you can manage the modules
Five Stars

Re: Updating the mysql-connector jar file to be used.

Thanks for your quick reply.
I added the jar file with no issue. That said, there are a few modules that are pointing to the 5.1.0 jar file and I would like to have those now reference the 5.1.14 jar file. Are you aware of a way to do this? It looks like the entries on this
tab are all read only.
Thanks again.
Five Stars

Re: Updating the mysql-connector jar file to be used.

Hi,
Take two on this issue. Does anyone know of a way to determine the mysql connector jar to be used as the default jar?
As suggested to me yesterday (thank you Saukema), I added the newer jar file as a module but it is not the default
jar being used. Having the two different mysql connector jar files resident in the same workspace is not ideal - I'd prefer to keep the clutter to a minimum and just have the one jar file.
Thank you.
Tom