Unspecified Red "Error!" Over Components

One Star

Unspecified Red "Error!" Over Components

Hi, with my current Job I have two red "Error!" messages at the top of my MysqlInput and tMap components
There's no message on hover, no error boxes pop up
Could someone explain the nature of these errors so I can address them?
Thank You Smiley Happy
Screen cap attached
Seventeen Stars

Re: Unspecified Red "Error!" Over Components

There is a problem view which contains all error messages and you can also switch to the code view (under the designer window) to find out whats wrong. In most cases such kind of problems are caused by invalid code in the properties of the components like an not existing context var or a missing double quota.
One Star

Re: Unspecified Red "Error!" Over Components

Thanks ok ? I can't seem to get the Problems view open on a Mac ? looks like ctrl+F3 is already taken by the OS
Is there another way to see it using the interface?
Seventeen Stars

Re: Unspecified Red "Error!" Over Components

You can open the view with the normal Eclipse methods:
Window->Show view->General->Problems
Do you ever have used Eclipse? Talend Studio is an Eclipse based application.
One Star

Re: Unspecified Red "Error!" Over Components

How the error indicate for the component ? "X" or "!" 
Moderator

Re: Unspecified Red "Error!" Over Components

Hi,
The red error x-mark indicates that there has compile error in your component.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.