One Star

Unlocking jobs in Open Studio

I had the misfortune to think I could import jobs from another project into my project. Now all I get when I try to open them is Null.Pointer.Exception
I try to delete them and it says they are locked.
How can I 
1) Unlock them
2) Remove them
I looked for other assistance on this but it told me I had to use TAC but TAC is not available with Open Studio as far as I can see.

6 REPLIES
Moderator

Re: Unlocking jobs in Open Studio

Hi,
Could you please go to Window-->ShowView-->Navigator to see if your imported job is right saved in new studio?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unlocking jobs in Open Studio

It says they are all there

But on the Repository Pane, there is no pyramid next to each job

Moderator

Re: Unlocking jobs in Open Studio

Hi,
Have you tried to restart studio to see if these jobs display in Repository? Can you remove them directly from Navigator? In addition, as we known that Talend forbid import of items from an upper version.
What's the build version of your source studio  and target studio?

Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unlocking jobs in Open Studio

OK, I have managed to delete them in Navigator. Is this the only way to delete jobs that are locked ?
Moderator

Re: Unlocking jobs in Open Studio

Hi,
Or you can delete them from workspace.
Have you already checked:TalendHelpCenter:How to import items and TalendHelpCenter:How to export items?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Unlocking jobs in Open Studio

I regularly use Import and Export and I always ensure I am importing from a lesser version or the same version of Talend studio. But even if I choose the directory I want to import into, it doesn't always show in the repository (or they fail to load as in this case)
Assuming the version is the same or less, how can I guarantee that they will always show in the repository after import ?